back to phpList.org

Need help to tune phpList with Amazon SES

Hi :slight_smile:

I have setting up a new phpList server with Amazon SES as API.
It’s working, but I have difficulties to tune it with my Simple Email Service limits.
In my case, it is the following : 14 emails per second
The total amount per day is not significant because I just have only 3000 mails to send a week.

I have set phplist like this :

define('MAX_PROCESS_MESSAGE', 999);
//define('PROCESSCAMPAIGNS_PARALLEL',true);
define('MAILQUEUE_BATCH_SIZE', 14);
define('MAILQUEUE_BATCH_PERIOD', 1);
define('MAILQUEUE_THROTTLE', 1);
define('MAILQUEUE_AUTOTHROTTLE', 0);

In my own understanding of the documentation, my conf should work.
But no ! The batch is running very slowly, approxymativelly 0,3 mail/second (=20 mails/minute)

I don’t know how to set it correctly ?

@Phinous Unless phplist on your server can generate more than 14 emails per second then you don’t need batch size at all, let phplist generate and send emails as fast as it can.

If that is too fast then a small throttle value to send less than 14 each second. Maybe throttle of 0.1s.

Thanks ! I will try on this way :slight_smile:

Another observation is that your config file says (limit the sending to 14/second), calculate it every second.
Also, you are putting a 1 second delay between the emails, which is most likely why you are sending 20/minute.
As @duncanc mentioned, change the ‘MAILQUEUE_THROTTLE’ to 0 (zero).
I would suggest that you send about 1/2 the maximum speed… so 7/second (your speed will vary), change the batch period to 10 minutes (600 seconds), and set the batch size to 600 * 7 = 4200.

also, I recommend setting up a cron job to automate the sending and bounce handling.