My URL going straight to the php list page

I’m sure this is an incredibly dumb question.

When I type my website URL, it goes to the the PHPlist page where it shows the option to subscribe to my newsletter, included with the HTML i customized and entered into the subscribe page editor.

But I don’t want it to do that. I want the banner that says “subscribe to my newsletter” to go to the phplist page. But I want my site URL to go to my homepage.

Is this simply because I haven’t uploaded my site files from my computer yet, and so don’t have a homepage and so its defaulting to there?

Or do I misunderstand something.

@ramy It sounds like you have installed phplist in the root of your web site instead of the default which is “/lists”.

If you have another web application that needs to be in the root then you have to move the phplist files to the “/lists” directory.

Hello, I ended up moving to a directory which I titled /newsletter

Is this ok? I changed the config file pageroot to match

@ramy The config entry should now be

$pageroot = '/newsletter';

You should also look at the Settings page to check the various URLs for subscribe, unsubscribe etc. Not sure whether they will update automatically or not.

Would that be related to my current problem, I was about to post about, which is that I am getting the below error message when trying to test adding a subscriber to my newsletter through the form. I also trie to send a test campaign to a subscriber email i entered manually, and the test failed. Maybe I have to enter the email settings differently. I’m trying to follow the manual.

“### Sorry, sending the message to request your confirmation failed, please click “Reload” to try again. If it still does not work, please contact the administrator.”

@ramy I don’t think that is related. Look at the event log page to see whether an error has been reported there.

the error i am getting in the log is Error sending email to SMTP connect() failed.

I think I just have no idea how to setup the config file properly.

@ramy You can enable smtp debug which should give more information.

Look in config_extended.php for an explanation then add the line to config.php


Then edit a campaign and send a test email (at the bottom of the page). The debug output will be displayed at the top of the page.

Hello, thanks for the suggestion. I was about to do that and Godaddy support got back to me. I was able to fix my specific issue, by changing “localhost” to my actual domain name, and changing port 2500 to port 25. Then it worked.