back to phpList.org

Issue with setting up email

After reading some threads and some testing. I believe my issue has something to do with how the mail is set up. I do not know if issue with host, program or a combination. I hope someone can help me find the answer.

Here is the problem. The phplist was set up and appears to work fine with the exception of sending emails. This sending emails includes campaigns, user verification, and any other emails that are sent by phplist to me and others.

I have tested by sending a campaign, signing up with another email address, and having information routed to my email. In all cases it says it was sent but emails were never received. I have also tried on another computer using another browser and another Windows version. This leads me to think it is either the host (which I do not understand how as they have nothing to do with the emails) or the program not set up to send emails correctly.

Anyone know where to check the setting and what to look for? I have checked the program itself and the only place I am not sure of if is right is under config – settings – Domain Name of your server (for email) I have my website domain there (mysorefigtreee.com). My email address that I use is a comcast email address and not through the host.

If this is not enough information, you need different information, or you need me to check something just let me know. I really would like to fix this issue soon

Could be :wink: http://www.mysorefigtree.com in fact…

The email servers are setup/configured in the ~/lists/config/config.php file…
You need to set it up there with whatever settings are appropriate.

Thanks. Jessie, I changed this and tested and no change.

Thanks danwaterloo, I can get to can can change but am not sure what to do with it (Not sure of what to change or how, this is my issue) here are the lines I added to the end as suggested from the install manual.

define(‘PHPMAILERHOST’, ‘mail.server.hostname’);
$phpmailer_smtpuser = ‘user@login.com’;
$phpmailer_smtppassword = ‘user_password’;
define(“PHPMAILERPORT”,‘587’);
define(“PHPMAILER_SECURE”,‘tls’);
$phpmailer_smtpoptions = array(
‘ssl’ => array(
‘verify_peer’ => false,
‘verify_peer_name’ => false,
‘allow_self_signed’ => true
)
);

I see it has a place for mail.server.hostname, user@login.com, and user_password. I just figured the config file got this information from above and did not need to be entered here. If I need to change these here I then need to know what to change them to or how to find out what to change them to.

It is hard to believe everyone has to do all this work to get the program to work. Makes me think there is something wrong somewhere just not sure where.

Thanks for your help

I did find the line(s) at the top of the file. Same place I had to enter some information during setup.

// if you have an SMTP server, set it here. Otherwise it will use the normal php mail() function
//# if your SMTP server is called “smtp.mydomain.com” you enter this below like this:
//#
//# define(“PHPMAILERHOST”,‘smtp.mydomain.com’);
define(‘PHPMAILERHOST’, ‘’);

Could someone please explain this to me and tell me what, if anything, to do about it.

Thanks and sorry I do not know much about this part of computer program setup.

The best way to set this up is to look at what the smtp settings are
from another client… for instance, I setup a new account using Thuderbird (or Outlook),
once that works for checking email and sending, use the SMTP
settings for phpList config file values.

Dan

lol I am so lost. I do not use any mail function either to receive or send through the host. If I remember right I did set it to forward any to my regular email that I use for the site which is my comcast email address. Here is what I have tried. Am I on the right track to fix the issue or am i changing in the wrong place?

I took the section at the top of the config file

// if you have an SMTP server, set it here. Otherwise it will use the normal php mail() function
//# if your SMTP server is called “smtp.mydomain.com” you enter this below like this:
//#
//# define(“PHPMAILERHOST”,‘smtp.mydomain.com’);
define(‘PHPMAILERHOST’, ‘’);
and in the bottom line I have used
smtp.mysorfigtree.com
smtp.mail.gridhost.co.uk
smtp.91.208.99.2:1217
smtp.10.169.0.224
smtp.mysorefigtree@comcast.net
smtp.mail.mysorefigtree.com
mail3.gridhost.co.uk (This is the SMTP server name)
none of these worked. kept giving me some kind of error and said no request was sent.

after chatting with my host it appears the website is not set up with authentication. i have setting but not sure i can fix. if anyone has an idea i am open to listen

thanks

What i do not get is it gives the option to leave blank if no smtp is used so why is it not just going with php mail()?

After doing some checking I think there is a plugin for phpList that will do the SMTP authentication. I think I have all the needed information but I only see old code from past versions of phpList. Can someone please help me set this up? At least I think I have the problem figured out I just need to fix it. Or if there is a plugin I can add to my website that would work for this too I will take that too.

thanks

Finally. First I want to thank all that gave me help and ideas. Next I found this from an old forum that might help someone else in the future, How can setup smtp server in phplist ?. This with where to find code from danwaterloo and help from my host, TSOHost, I pieced together what I needed to fix the problem. Just for the record I had to use port number 587 and not the one on my host. Just saying to help others with same problem.

I just kept testing ideas and code until I got it to work.

Thanks again