Installation problem

Hello,

I’m trying to install phplist on a new server.
I’m only changing server and I had phplist on my old server.

I have created the database and the user and the password. Everything is the same as my old server.

I have different choice of php and I always have different error message following the php that I choose.
Unknown database host to connected to,
Cannot connect to database, Sql server is not running
It’s Odd there is Nothing there

My config is fine . It has been check and recheck.

I don’t know where is the problem.

Can somebody help.?

Thank you very much

Okay, you have created a new db, user, password etc, have you changed the details in your config file?

Specifically it will probably have a different prefix to your database name. Also, has your change of server involved a new database host address? On one of my hosts localhost is useable, on another I have to specify a specific IP address.

Thank you for your reply

for the host address: localhost, the domain naim or the numbers of the url doesn’t change anything

the name of the database and the user and the password is the same as the old server.

I have a dedicated server and the domain is on dedicated IP address.

On my old server it works fine but if I change the PHP version the problem is the same
I can only choose Php version 5.1.6 vendor apache module, vendor cgi application or vendor Fast CGI

In my new server I can choose PHP version from 5.2.17 to PHP 7.1.17 and the error message differ following which PHP I choose… I already have trie almost all the version.

So now I’m stuck

Can somebody find a solution?

Thank you

@Phil You will need to give the values for the database connection fields in your config.php file, the exact error message that is displayed, and the version of php that you are using. Otherwise we would just be guessing.

Hello

with $database_host = ‘localhost’;

I have the following message

HTTP 500 error
That’s odd… the website can’t display this page

with $database_host = ‘domaine.com’;

Php version 5.4.16

button checked Php support (php version “5.4.16 by os vendor” run php as “FPM application served by appache” or FastCGI application served by Apache

I have the following message
Unknown database host to connected to, please check your configuration

with $database_host = ‘domaine.com’;

Php version 5.4.16

button unchecked Php support (php version 5.4.16 by os vendor run php as “FPM application served by appache” or FastCGI application served by Apache

I have the following message
HTTP 500 error
That’s odd… the website can’t display this page

beginning of my config.php

<?php /* * ============================================================================================================== * * * The minimum requirements to get phpList working are in this file. * If you are interested in tweaking more options, check out the config_extended.php file * or visit http://resources.phplist.com/system/config * * ** NOTE: To use options from config_extended.php, you need to copy them to this file ** * ============================================================================================================== */ // what is your Mysql database server hostname $database_host = 'domaine.com'; // what is the name of the database we are using $database_name = 'lists'; // what user has access to this database $database_user = 'jhlwlist'; // and what is the password to login to control the database $database_password = 'xxxxxxxxx'; // if you have an SMTP server, set it here. Otherwise it will use the normal php mail() function //# if your SMTP server is called "smtp.mydomain.com" you enter this below like this: //# //# define("PHPMAILERHOST",'smtp.mydomain.com'); define('PHPMAILERHOST', ''); // if TEST is set to 1 (not 0) it will not actually send ANY messages, but display what it would have sent // this is here, to make sure you edited the config file and mails are not sent "accidentally" // on unmanaged systems define('TEST', 0); /* ============================================================================================================== * Thank you

@Phil
The 500 errors are probably masking the underlying problem.

I think that you need to ask the hosting company what the database connection details are. If you have a hosting control panel then sometimes that explains what to use.

Also, ensure that the mysqli extension is enabled in php.

yes msqli extensions are enabled

I have tried localhost, the name of the domùain and also the IP adress but it doesn’t change anything

You might want to try upgrading your php to a more recent version.