back to phpList.org

Instalation without control of DocumentRoot and folder where I put phpList

Hi all,

I am installing a phpList on a server where I cannot change the DocumentRoot for apache (etc/apache2) or the folder where I can put the code (/opt/sites), the installation is up, but I have the error message:

The pageroot in your config does not match the current locationCheck your config file.

Any idea how I can work this? Or is it impossible?

Thanks all!

@lucaslago Please show your config.php setting and say where phplist is actually installed - the path to the phplist admin directory.

config.php with comments removed

<?php

$database_host = 'localhost';

$database_name = 'phplist';

$database_user = 'phplist';

$database_password = '*************';

define('PHPMAILERHOST', '');

define('TEST', 1);

$pageroot = '/phplist';

$language_module = 'portuguese.inc';

$bounce_protocol = 'pop';

define('MANUALLY_PROCESS_BOUNCES', 1);

$bounce_mailbox_host = 'localhost';
$bounce_mailbox_user = 'popuser';
$bounce_mailbox_password = 'password';

$bounce_mailbox_port = '110/pop3/notls';

$bounce_mailbox = '/var/mail/listbounces';

$bounce_mailbox_purge = 1;

$bounce_mailbox_purge_unprocessed = 1;

$bounce_unsubscribe_threshold = 5;

define('HASH_ALGO', 'sha256');

phpList is in /opt/sites/phplist

adding the result of a sudo apache2ctl -V

Server compiled with....
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=256
 -D HTTPD_ROOT="/etc/apache2"
 -D SUEXEC_BIN="/usr/lib/apache2/suexec"
 -D DEFAULT_PIDLOG="/var/run/apache2.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="mime.types"
 -D SERVER_CONFIG_FILE="apache2.conf"

@lucaslago What is the URL path to access phplist e.g. https://mysite.com/???

This is the line of code that triggers the warning, can you see why it is happening?

if (strpos(getenv('REQUEST_URI'), $pageroot.'/admin') !== 0) {

well, I changed the URL to newsletter.test.mywebsite.com and left the $pageroot blank.

That solved the issue for me! =)

Thanks for the help @duncanc !!