Initialise the Database Continue button doesn't do anything

Hey all :smile:

I uploaded the lists directory to my server, created a database called “phplist” and granted my user permissions, then went to /lists/admin on my website and tried to initialise the database. I entered everything I believe fine including a long password, but the Continue button does absolutely nothing both on Chrome and Firefox.

Any thoughts?

Thanks :smile:

Can you share a screenshot of what you see? You can add it to a service like imagebam if you cant post it here yet

Something is not right… I’d probably delete the database, and database user, and start over. It should initialize. It could be something like the database user does not have permissions to create tables or insert rows… (this is a mysql issue, not phplist) so you need to go back and check it all out.

1 Like

Same thing here @Hoppimike … I followed @danwaterloo suggestion and re-assing privileges to DataBase User… and double check User is assign to the DataBase as well… no luck so far…

Any thoughts?

after install of 3.2.3 (new install)
db new and ready,
db master user has all permissions
all worked well with 3.2.1 but not with new version…
briefly get a db error 1146 and it goes to initialise the database
This brings up the items for login but the continue button acts as if not linked to anything. nothing past this point…

Ok, asked the dev;s for some exta info

  1. What PHP version do you have
  2. Check your password is over 8 characters long (the admin pass you enter in that form)
  3. What browser and version



php 5.5.26
It all had to do with the version of php… added the following to my htaccess file and the initialise database works fine.

my site has 3.3 as the default and 5.5 available, so i added

AddHandler application/x-httpd-php55 .php

My friend managed to fix this by removing the verification that the Continue button runs, so it doesn’t check the fields for errors it just accepts them.

Works fine then!

Nothing wrong with what I entered though - just name, company name, email and a long password.

No mistakes, just doesn’t like them until we force it to ignore errors o.O

Did you type the long password or copy/paste?
Your comment reminded me that this problem has been reported before, as the password length is tested within a keyup event.

Copy/paste of a password into the password field using ctrl-v works, but pasting using mouse right-click doesn’t enable the Continue button.

1 Like

I also just faced the problem. It appears to me it is a problem with the button being disabled by default in the html, as when I removed the following snippet from the continue button within the initialise.php file, and uploaded it to my server, it worked fine…

I was going to send this in feedback on the next page, but it appears that button also has the same snippet of code too, so when i tried to submit nothing happened again. Hopefully I won’t have to keep on repeating this throughout the process.

I also got royally stuck, the continue button only worked after I added a space are the password