Images only appear on test emails

Hi! Thank you so much for phplist, been using for years.

My traffic went down quite a bit, only to realize that images were not appearing anymore in my monthly newsletter.

The strange thing is, when I test the email (send test), the images appear fine, but once it gets sent as a scheduled email, the images are blank.

Have to mention the content comes via a rss feed, so embedded and not uploaded in ckeditor.

I have checked that hot linking and permissions is not an issue.
Server Apache running PHP 8

Whats baffling it only happens on ‘auto responder’ and ‘scheduled’ mails, but not the test mail.

Any ideas and guidance most appreciated :tulip:

Just a quick update: in fact even with ckeditor uploaded images, also does not appear in email.

Only when sending a test :sweat_smile:🥹

@Liliplanet Look at the html source of the “good” and “bad” emails to see how the image elements differ.

Duncan hi! Thank you so much for your response. On my, if you only knew (months) what I have done to try fix this.

Changed server, rebuilt phplist, rebuilt my 12 year old website :sweat_smile: thought it was a bug somewhere.

As I am on a mac and ipad, turns out apple mail does not accept any tracking pixels in an email and will not load images due to ‘security’.

So we found the culprit, it’s apple :slightly_smiling_face:

In config set ALWAYS_ADD_USERTRACK to 1 as per system:config:always_add_usertrack [phpList Resources]

Still images do not show in emails that are scheduled, repetitive or autorespond …

  • but the wild part is, it works (images show) on test email.

  • that means there is still a tracking pixel in there perhaps?

Other tests done:

Passed ssl security test: SSL Server Test (Powered by Qualys SSL Labs)
All privacy settings set to ‘off’: Images Not Displaying in Mail on Mac? Here's the Fix! - Saint

Going insane :crazy_face:

Tried setups:

Send a webpage (monthly): Funding
Tried repetitive RSS feed: Film Grants

Test email shows image, any other, images are ‘blank’ :smiling_face_with_tear:

Any ideas most appreciated, thank you so much Duncan :tulip:

@Liliplanet To clarify, you think that this is a problem only for apple ipad, and images are displayed as expected with other email clients such as gmail, outlook, yahoo?

You should compare the email html source of a “good” email with that of a “bad” email to see what the significant differences are.

Correct Duncan, I’ve tested on gmail, etc, it works, but apple (80% of my film clients) are on a mac. Its a new thing (latest mac upgrade) that does not download images re security.

It seems specifically due to any tracking that is an issue. What a nightmare for marketers.

Server tech even switched off security ie boxtrapper, no avail.

As I say, why would it work with test mail (images show), any other repeat, schedule, auto response, no images :stuck_out_tongue_winking_eye:

Oh just in response to your question re mac Duncan. It’s an issue with all apple mail on ipad, iphone and mac desktop.

Not only rss feeds, fetch as webpage, but ckeditor uploaded images as well.


Images do not show in mail, only appears when sending test mail.

I have switched off every possible tracking in config.php, but tracking still counts views.

define(‘REGISTER’, 0);

As mentioned, images appear on mac mail when sent as a test …

but when auto respond, scheduled or repeat, I got a feeling there is still a tracking pixel in the mail that mac regards a privacy issue, so no images.

Tracking is still there even with no [USERTRACK] in html or template, and all settings switched off.


If I understand correctly, apple first caches the email, then re-routes to your mail server. If a tracking pixel is found, it disables the images


Please, how do I switch off all tracking pixels, although all disabled in config.php, still counting opens.

Most appreciated, thank you Duncan :tulip:

@Liliplanet Your statistics are showing no views so user tracking is disabled.

You said that a test email does display images. If that is still the case then as I suggested previously you should compare the html source of the “good” and “bad” emails to see what is different.

I don’t know whether it is significant but the URLs of the images have a token appended. What is that for? It might be being treated as a tracking device

Thank you so much Duncan, so kind of you.

So changed the image without ?itok (which actually just creates an image size in Drupal), but that didn’t work either.

Even installed another phplist on my main domain, made images relative, not displaying either.

RSS feeds and ckeditor, all the same issue.

Unfortunately not able to view source code of apple mail.

Guess the only step is to give apple users link to ‘view in browser’ capability. It’s definitely over 60% of my filmmaking subscribers.

Most appreciate your awesome support!

Thank you Duncan :tulip: