How to turn of batch processing?

I want to sent all mails out at once, so I tried to turn off batch processing:


But it showed no effect, only about 20 mails per minute are sent. What am I missing?

Although I got there in a different way, I have a similar experience.

Even with batch-size set at 0 to turn off batch processing, only a small number of messages are sent. I found that when I applied a mail queue throttle of 45 seconds, 7 messages were sent and then the sending stopped. Reducing the throttle to 40 seconds increased the messages to 8 before stopping.

What are your other settings?

# define the amount of emails you want to send per period. If 0, batch processing
# is disabled and messages are sent out as fast as possible

# define the length of one batch processing period, in seconds (3600 is an hour)

# to avoid overloading the server that sends your email, you can add a little delay
# between messages that will spread the load of sending
# you will need to find a good value for your own server
# value is in seconds, and you can use fractions, eg "0.5" is half a second
# (or you can play with the autothrottle below)

It may be the case that your host is limiting how many mails you can send in a specific period.

I just set the MAILQUEUE_BATCH_SIZE to 0. I assumed that turning off batch processing makes the other options redundant.

I’m sending through an external Microsoft server, so there is no limit.

I’m not sure about 0711master, but:
my hosting service imposes limits of 19 messages / minute, 100 messages / hour, and 10,000 /day

My settings are: batch size – 0 and batch period – 3600. When I used mail queue throttle – 45, phpList sent 7 messages and stopped; when I used throttle – 40, it sent 8 messages and stopped.

Earlier on, I had batch size of 5, periods of 500 and 225 – each of which resulted in just 1 message being sent and then stopping.

I also set define('MAILQUEUE_THROTTLE', 0); now, but no effect. Still only 25 emails per minute.

just to make sure, you are making these changes in the config.php file, not the config-extended.php file

Haha, yes… :slight_smile: