How do I keep my own formatting, line breaks and spacing in a sent campaign?

Hi all.

Cards on the table right away, I’m very new to phpList and far from an expert in most of the skills and knowledge that go with using it, so apologies in advance for any stupidity on my part here.

I’ve been trying to get rid some of the automatic spacing / line breaks that CKEditor imposes when it sends a campaign. When I format text in the editor it looks as I want it to, with single line breaks or
variations between some of the lines. But then this is lost in the campaign when it’s emailed out. Those lines that I want single line breaks on end up looking like this:





Spaces between paragraphs are fine The problem is only with places where I want single line breaks - so, I want the text to look like the below:


I’ve imported from Word, TextEdit, typed into the editor manually, gone into the source code and inserted line breaks, but nothing seems to stick when the campaign is emailed out.

Any ideas on what I’m doing wrong or how I can get around this? Have tried for hours and can’t get a result, desperately hoping someone can advise. I’m using phpList version 3.2.4 in Chrome. Thanks in advance for any help.

What do you mean by this? If you look at the underlying HTML using the Source button in the editor and by viewing the HTML source of the email that you receive, then you might be able to explain the problem more clearly.

In ckeditor, the enter key creates a new paragraph. If you are trying just to move to the next line then you need to use shift+enter, just like in Word.


If you want to be in total control of the html you need to turn off the WYSIWYG editor. This can be done in the plugins section of Config menu. The editors mess with your html I think


Hi Anna.

Thanks very much for your reply. I think I’ve found a different way around
by installing a plugin, but will certainly try the method you suggest above
too, as it sounds like it could be useful for future problems.

Thanks again for your advice.


Hi Duncan.

Thanks for your reply. I think I’ve found a way around through a plugin,
but if the problem persists or anything else comes up I’ll try and give a
more thorough explanation for future issues.

Thanks again.


So do share the solution for others :wink: :smile:

Ah yes of course! Good point. Someone helped me install the plugin, so I’ll
check in with them for info and then post.

1 Like