back to phpList.org

Hiding the Auto Updater


#1

Is there a way to hide the auto-updater message and the auto-update menu item. I’ve added my own language set and don’t want the system auto-updating it to oblivion.

Thanks … Doug Davis


#2

If you are using v3.3.8 or later and you want to disable the automatic updater and its notifications, add the following in your config.php:
file:
define(‘ALLOW_UPDATER’, false);


#3

For some reason, that’s not working on my system… the updater keep showing the use the updater notification 3.39


#4

I have added to my config and it works. BE SURE you have the semicolon at the end of the line.

I put it into the security related section immediately below the $Check for Host line.

I will paste a sample here …

# to increase security the session of a user is checked for the IP address this needs to be the same for every request. This may not work with

# network situations where you connect via multiple proxies, so you can switch off the checking by setting this to 0

define("CHECK_SESSIONIP",0);

# Check for host of email entered for subscription Do not use it if your server is not 24hr online

# make the 0 a 1, if you want to use it

$check_for_host = 1;

# AutoUpdater switch as described by Support

define ('ALLOW_UPDATER',false);

/*

=========================================================================

Debugging and informational

=========================================================================

*/

… (NOTE: the Bolded lines have a # before them) Hope that helps!

Doug Davis


#5

Thanks @Dougster,
It turns out that I copied the line from @xheni which didn’t work.
Your code worked.

The apostrophes were not the proper character for php to interpret…

//this code works--
define ('ALLOW_UPDATER',false);
 //this code does not work--- note improper apostrophes...
define(‘ALLOW_UPDATER’, false);


#6

@danwaterloo It’s a problem with the Discourse software. It changes single quotes to so-called “smart quotes” (66 and 99 type) when you copy and paste. I think that doesn’t happen when you use the code button </> though.
e.g.
define(‘ALLOW_UPDATER’, false);

define('ALLOW_UPDATER', false);

@samtuke Sam, can you see whether this is a configuration option that can be changed? I remember this has happened before.