[HELP] HTML template doesn't show up correctly

Hi everyones!
I’m working on a PHPLIST installation for a client, but I cannot correctly save a newsletter template in order to permit to a final user to send himself emails.

I create the template in HTML and I upload it in the editor (by clicking on source code button) just before the ending of [CONTENT] placeholder and then I paste the ending of my newsletter. I save the template. now I go in the New message section and I write the content. In the footer section I delete everything because already included inside template. I send email for a test and my layout is a little decomposed.Then, I’ve tried to paste the final part of my email template (I mean all the code after [CONTENT]) directly in the footer section, email is perfect. It seems that PHPLIST don’t want html after content placeholder.

Can U be so kind to help me! :smile:

Thank’s in advance


Hi, I don’t understand everything you describe, can you check through the manual here https://phplist.org/manual/ch020_templates.xhtml and make sure you have got everything set up right?

Which editor are you using? If it is CKEditor then only one of these settings should be set to Yes. Because you are using templates then the second should be set to No.

Allow templates to be edited as full HTML pages
Allow messages to be edited as full HTML pages

thank you!
I’ve read it but no clues.
I try to explain better.
I go to create a new template section and paste in the content editor the example provided with phplist (system template):

<div style="margin:0; text-align:center; width:100%; background:#EEE;min-width:240px;height:100%;">&nbsp;
<div style="width:96%;margin:0 auto; border-top:6px solid #369;border-bottom: 6px solid #369;background:#DEF;">
<h3 style="margin-top:5px;background-color:#69C; font-weight:normal; color:#FFF; text-align:center; margin-bottom:5px; padding:10px; line-height:1.2; font-size:21px; text-transform:capitalize;">[SUBJECT]</h3>

<div style="text-align:justify;background:#FFF;padding:20px; border-top:2px solid #369;min-height:200px;font-size:13px; border-bottom:2px solid #369;">[CONTENT]
<div style="clear:both">&nbsp;</div>

<div style="clear:both;background:#69C;font-weight:normal; padding:10px;color:#FFF;text-align:center;font-size:11px;margin:5px 0px">[FOOTER]<br />

this is the preview in the editor:


now I’m go to create a new message and fill the content with my text or images.
Finally I fill even the footer section with unsubscribe and some further information.

when I send a email to account, this is the result:


the bottom of my newsletter is cut off.

can someone help me to solve this issue? many many thank’s

I see right now your reply. I’ll check. thank’s!

YES! it works! now emails are correct! thank you!

1 Like

Is that setting something that most users would edit, ot is this just a random thing? Is it documented anywhere?

It’s in the plugin installation instructions. In this case the problem reporter had changed the default settings without either reading or understanding the effect of that.

Ah, ok. Can you add a line in the docs to explain that it is one or the other not both :slight_smile:

I had the same problem and lost days of research to resolve this problem. The solution to turn off “Allow messages to be edited as full HTML pages” is still NOT mentioned in the phpList manual and it is 2023 now!