Gmail and Yahoo Mail announced a new set of requirements for senders

Anyone else received this email from AWS? I am wondering if phpList is ready to deal with these new requirements?

n a move to safeguard user inboxes, Gmail [1] and Yahoo Mail [2] announced a new set of requirements for senders. Effective February 2024, the new requirements affect email senders who distribute over 5,000 bulk messages per day or have >0.3% of messages reported as spam. Failure to comply with the new requirements may result in Gmail and Yahoo rejecting message delivery to their customers.

For more information on the new mailbox provider requirements and how to comply, please visit the AWS blog [3]. If you have any questions or concerns, please reach out to AWS Support [4].

[1] Gmail introduces new requirements to fight spam
[2] Postmaster @ Yahoo & AOL — More Secure, Less Spam: Enforcing Email Standards...
[3] An Overview of Bulk Sender Changes at Yahoo/Gmail | AWS Messaging & Targeting Blog

Amazon Web Services

@UtopiaOperaX There’s not really anything new there, just what is already good practice. Yahoo and Gmail are going to be rejecting emails that do not follow those requirements.

You should have DKIM and SPF setup as explained in their reference [3]. phplist already provides the 1-click unsubscribe function, and you should also be including an unsubscribe link in each campaign.

1 Like

So the unsub headers aren’t strictly required as long as there’s a one-click unsub link? I’ve used SPF and DKIM for a while, only I’ve always just included the “regular” unsubscribe link.

I do seem to have an issue with the [UNSUBSCRIBEURL] tag however. Dropping it in the email on its own works as expected when clicked, if I place inside an anchor tag though, when clicked it goes to the standard unsub page, the one where you have to type your email address in?

Here are the HTML href outputs when placed inside an anchor vs when not:

<p>To unsubscribe, <a href=3D"
dn-a1WUADawRKSC-6_FlA=3D356" >click here</a></p>

@UtopiaOperaX the 1-click link is a header, so not directly visible to the subscriber. You need to have an unsubscribe link in the body of the email as well.

You appear to be using another click tracking method as well as phplist. I guess that there is scope for that not to work properly.

Honestly at a bit of a loss as to what that could be, I’m not directly injecting anything, I’m literally just adding the [UNSUBSCRIBEURL] tag to an href=“”. I disabled the anlytics tracking code option on step 6 just to see if it was that but same result.

Indeed, the uid code from embedding without the anchor, isn’t present in the anchored params at all, it’s just a completely different url.

EDIT: So looks like AWS is encoding any links?

<a href=

I disabled something called “Opens and Clicks” tracking in AWS, obviously I thought that was dead-cert to fix it, but the link is still behaving strangely (going to /?p=unsubscribe when clicked) and getting encoded into some other form, this is the url now after disabling AWS tracker:

<strong>Unsubscribe</strong> from Fastlove <a href=
a><br />

To clarify, the link isn’t passing the uid=**** parameter through when placed inside an href.

OK, it gets a bit weird.

I noticed using the url param ‘email’ and plain text email address does the same thing, so I used [UNSUBSCRIBEURL]&[EMAIL]… works!

I then decided to just try href=“[UNSUBSCRIBEURL]&” … and just adding the & char to the url like this makes the clicked url work (uid param is passed in url)!

The URL looks like this:

Notice ‘&&’, but it works…

Question is, why isn’t it working with just [UNSUBSCRIBEURL] ?

Also note [PREFERENCESURL] does not have the same issue, that works as normal.


@UtopiaOperaX Look at the linktrack_forward table in the database for the row with the url column including p=unsubscribe , there should be only one such row.

The value of the personalise column should be 1, is that the case?

I have 17084 rows LIKE% p=unsubscribe% - and 3 of those rows have personalisation = 1.

You should have only one or two rows similar to this, using https and http

It looks like something hasn’t been working properly. What value do you have on the Settings page for the field URL where subscribers can unsubscribe
That should be similar to with no other parameters.

Actually, those might be caused by your including the [UNSUBSCRIBEURL] on its own. I’d be inclined to delete all of these to let phplist start again. That would mean any clicks of the unsubscribe link in existing emails would not work.


So 17,000 unsub links isn’t a good look? I can tell you the third personalise entry is http://https//...mysite....

Should I delete all the others?

Right OK, and you think that will solve the [UNSUBSCRIBEURL] param issue once deleted?

Aye, only bloody works now! Thanks Duncan.

I’m wondering if it was that random one with the url “http://https://” & personal = 1 that was buggering it up.
Anyway, sure deleting 17k rows has freed up a few MBs in the db department to boot!

Thanks again.