back to phpList.org

Fatal error: Your version is older than 3.2.0 and cannot be upgraded to this version

Installed a fresh copy of phplist a month ago, tested a few plugins and everything went well, I even tested a few emails with no issues.
Decided to upgrade to latest version 3.3.3 today and get his on my dashboard:
Error: Your database is out of date, please make sure to upgrade
Your version : dev
phpList version : 3.3.3
When I click on Upgrade I get this error:

"Fatal error: Your version is older than 3.2.0 and cannot be upgraded to this version. Please upgrade to 3.2.0 first and then try again. "

I know I have the original install later that 3.2 so why this error ? Any ideas how to fix it ?

Regards,

@vguzman You were originally running a development version of phpList, probably installed from GitHub or via an RC release. Your database version is ‘dev’ therefore and not recognised as safe for upgrade. You can manually change the version of your database by editing the config value in your database. Or you could start with a fresh database.

You are using dev version(probably installed from https://github.com/phpList/phplist3) that’s why you see this error. You can manually change the version in the config table to something like 3.3.1.

I created a PR to fix this issue.