Error: phpList Requires PHP 5.3.0 or Higher

Just upgraded from phpList 3.2.3 to 3.2.4. Been using phpList since version 2.10.19 a couple of years ago. Usually no issues after each upgrade, but seeing the below error regarding PHP whenever logged into admin account. Also on Firefox 42.0.

Upgrades for me have always been: backing up database, modifying config.php and files, uploading lists folder to public_html and all done.

Question: do I upgrade PHP via cpanel at my site’s hosting company (Bluehost, btw)? Never done anything with PHP before. Thanks in advance for any insights.

@PresterJohn You don’t upgrade php in the same way as upgrading phplist. Look on your cpanel for a “Select php version” icon within the Software and Services group.

If present that will let you choose a later version of php.

If the icon is not present then you will need to ask your hosting company to either add it to your cpanel, or to change the default version of php.

phplist runs fine with the current version of php, which is 5.6.

Thanks for that, Duncanc. As luck would have it, Bluehost is not as straightfoward as your cpanel. They offer 2 options: Under Programming, a “PHP Config” like you see below; or a tutorial for “Adding handlers to change your PHP version” under File Manager.

Unfortunately Bluehost’s tutorial does not match what I’m seeing in File Manager (and I just told them so).

If I use the “PHP Config” option below, do I tick that first button for PHP 5.4 and that’s it? I’m hesitant to dive in as this comes with a strict “you-break-you-pay” warning. Any other thoughts?

Do you use any other php applications, such as wordpress? If not then you should be able to select php 5.6, otherwise it might be safest to use php 5.4. Despite the caption, php 5.6 is not beta software.

I’m not sure of the implications of the single php.ini options. If you know that you don’t have a custom php.ini in your web root directory then choose the first or fourth options, otherwise the second or fifth.

This is getting interesting, Duncanc. Besides the site that uses phpList (located in the public_html/ folder) I have one subdomain (public_html/secondsite) that runs on Wordpress and another (public_html/thirdsite) built using – just to make the situation a little more volatile, lol.

I think I will back up the public_html/php.ini file, try the first option PHP 5.4 and see what happens. Will let you know!

Duncanc, I went with your alternate suggestion, upgraded to PHP 5.4 via cpanel, and it worked. Thanks again.