back to phpList.org

Error: Incorrect processing secret

If a curl or url method I get failures:

"https://…/admin/?page=processqueue&secret=f8282c4355…" successfully completed in 1 seconds, output:

Url ‘https://list.istok.de/admin/?page=processqueue&secret=f8282c435557bc9vvvbb’ fetched
Status: 200
Output:
Error: Incorrect processing secret

I wrote about this on twitter, maybe there I get help. Update after update and it still doesn’t work with same error by crone job :frowning:

@dreamcreator

https://list.istok.de/admin/?page=processqueue&secret=f8282c435557bc9vvvbb

Is this deliberately changed? The value to use is on the Settings page within Security settings.

I changed this key hoping it will work again. Don’t want to post full url here. but in cronjob is the same as in the settings

@dreamcreator which version of phplist are you using?

Also, confirm that this is the field you are using
image

today updated: Thu, 28 May 2020

phpList 3.5.4 released: Security Release

I changed the key to this from your picture, the same:

Url ‘https://list.istok.de/admin/?page=processqueue&secret=f8282c435557bc9vvvbb’ fetched
Status: 200
Output:
Error: Incorrect processing secret

failure wit url cronejob:

Url ‘https://list.istok.de/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee’ fetched
Status: 500
Output:

500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator to inform of the time the error occurred and of anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


faulure with curl:

Task “curl ‘http://list.istok.de/lists/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee’” completed with error in 0 seconds, output:

Could not open input file: curl ‘http://list.istok.de/lists/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee

@dreamcreator What is the correct url to access phplist? Your last error message includes “/lists” which the earlier url did not.

In your curl command you need to surround the url with single quotes

curl 'https://list. .... '

I tried url cronejob

https://list.istok.de/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee

and curl method:

curl ‘http://list.istok.de/lists/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee

You need to use the same url as you access phplist admin. Please show the exact command that you are using, do not retype it use copy/paste or take a screenshot.

bcc1b4c17e4d0bef83ee is the value in my phplist, it is not going to work for you unless you have changed your secret value on the Settings page.

Update
This command works for me

curl 'https://list.istok.de/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee'

curl method still doesn’t work but url seems seems no more to produce errors

@dreamcreator I do not understand how you are meant to specify the command. Are you meant to include the curl command? You should ask the hosting company why the commands are failing.
This works for me

I just swa this somewhere on the forum, but it already had worked with this Strukture. I will ask my provider. Sofar I am happy that the URL now works. Will see for how long. Thank YOu!

with manually activating url cronejob was without failure

but my joy was to early.

Just arrived vie email:

Cron istok@ha01s021 /opt/psa/admin/sbin/fetch_url ‘https://list.istok.de/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee’ > /dev/null

Url ‘https://list.istok.de/admin/?page=processqueue&secret=bcc1b4c17e4d0bef83ee’ fetched

Status: 500

Output:

500 Internal Server Error

Internal Server Error

The server encountered an internal error or

misconfiguration and was unable to complete

your request.

Please contact the server administrator to inform of the time the error occurred

and of anything you might have done that may have

caused the error.

More information about this error may be available

in the server error log.


Web Server at istok.de

@dreamcreator I am guessing that you need to enter only the URL, not the complete curl command. But you should clarify this with the hosting company or review any documentation.

I give only the url but in the alert it is wit ’
Anyway I will a provider.
Thanks a lot for now :slight_smile: