Cron set up problem

I set up cron and commandline for Php-CLI version, but I m getting "Connot find config file" error while I m sure that all the paths are correct :

#!/bin/bash
/usr/bin/php /var/www/html/lists/admin/index.php –c /var/www/html/lists/config/config.php

to process on commandline

phplist -pprocessqueue

or with cron job :

13 * * * * /usr/bin/phpList -pprocessqueue > /dev/null 2>&1

all the time I m having same problem. Besides, I have done everything in this manuel :

https://www.phplist.org/manual/ch036_setting-up-your-cron.xhtml

inluding to change

define ("MANUALLY_PROCESS_BOUNCES",0);
define ("MANUALLY_PROCESS_QUEUE",0);

and

chmod 755 /usr/bin/phpList

Hi,
What kind of host is this installed on?
a ‘private’ host, where you don’t share the machine with anyone else?
Do you have access to the command line, and can you run the commands? Getting cron jobs to work consist of two steps… 1. Figuring out what the commnand is, based on your particular server, and 2. settting up the cron job with the command from #1.

If you can answer the two questions, we can first work on what the command is.

Hi,

I m using CentOS based VPS, hence, I have access to the command line and run them. However, I did not understand what you mean with " Figuring out what the command is" .

Hi,

You should first determine what command will process the queue, and the
other command which will process the bounces.

As an example, these work on my server:

/usr/bin/php -q /var/www/html/lists/admin/index.php -p processqueue -c
/var/www/html/lists/config/config.php

/usr/bin/php -q /var/www/html/lists/admin/index.php -p processbounces -c
/var/www/html/lists/config/config.php

looks like processqueue command is not recognize by my system. I have no idea about with which command I can replace it with in CentOS.

@EJERS Your first post with the commands is a bit confusing. If /usr/bin/phpList is a shell script then it is missing $* at the end to propagate the parameters.
Also, don’t discard the output. Save it to a file instead otherwise you have no way of seeing any errors.

Thank you duncanc , you were right $* was missing, so I fixed it but still I m having same error message "Connot find config file" . Is it possible that there is a problem with processqueue command. Because I have tried all the variations of -pprocessqueue or -p processqueue it but no chance to see that it is working. Besides -help command says nothing about processqueue.

@EJERS What happens when you run the complete command, not using the shell script, from the command line?

@duncanc when I run the complete command

/usr/bin/php /var/www/html/lists/admin/index.php -p processqueue –c /var/www/html/lists/config/config.php

I got same error.

Connot find config file

@EJERS You have now repeated the misspelt message “Connot find config file” three times. Is that really the actual text or do you just have a blind spot with it?

Try removing the spaces in the command after -p and after -c