phpList.org

Common plugin would not update/ phplist fails to detect correct version of plugin

I have updated the files of the common plugin. I even renamed the directories and uploaded the new ones, but under config>Manage plugins it still says version3.6.3+20170601.

admin/plugins/CommonPlugin/version.txt says 3.15.0+20210207

Other plugins would not work, as they require a later version, so this is an issue.

Thanks!

Oh, it appears, that there was another copy of the plugin in the plugin directory in a folder named phplist-plugin-common-master. Once I deleted that, the issue resolved.