Command line sending suddenly stopped

I have been using Php command line sending for a while now and suddenly it has stopped working. I can see that the cron job are launching the process and it is running but just not processing. I can process the queue through the normal web access. Also I downloaded latest version just in case something got corrupt. I’m on and their support has gotten pretty bad so they were no help. Its also weird I removed >/dev/null 2>&1 and not getting emails from cron even though I do for other cron jobs. Any ideas or thoughts?

Thank you

This usually means that something has changed, if not by you, by your less than wonderful host from what you say.

Also, Please, help us to help you, cheers.

[quote]The information below will be super useful to those trying to help you:

The version of phpList you are using.
Your server version of PHP
The url to your installation where possible. (eg:
Which browser (and version) you are using to view your site.
Is your installation self-hosted or on (In which case, your best option is to submit a support ticket).
What exactly is the issue (screen snapshot can be helpful).
What you have done to try to fix the issue so far, including links to any documentation you have followed.

Be secure: please do not give passwords, ftp access details or email addresses out in the forums.[/quote]

I’m using Hostmonster also. Just sent a test campaign using cron and everything worked OK.

Php version 5.4.24
Phplist version 3.2.5
Self hosted

My Cron job line:
php-cli /home/USERNAME/public_html/SITE/lists/admin/index.php -pprocessqueue

Thank you

Since this was working before, probably something else is the problem but I’ll throw this out there.

Hostmonster provides both version 5.4 and version 5.6 of PHP. In my cron job I specify I want to use version 5.4 as in the example below. Also I have a space between “-p” and “processqueue” and a space after “-c”. Not sure if either of these differences matter.

/usr/php/54/usr/bin/php-cli -q /home2/USERNAME/public_html/SITE/lists/admin/index.php -p processqueue -c /home2/USERNAME/public_html/SITE/lists/config/config.php >/dev/null

Thank you Steve. That seemed to have worked. I had to change mine to home versus home2 I not sure what that was I assume some other custom setup. But in general it must have been grabbing a different php that was not making it happy.

Glad I could help. Actually, /home will work for me also. /home is a symbolic link (set by Hostmonster for your account) pointing to the actual directory (/home2 in my case).