CKEditorPlugin gives 404 when trying to Browse

I have been trying to move my site to a new server and have only one piece still not working. With the old one, we used the FCKeditor to add images to emails before sending. I was told to change over to the CKEditor as it works better. When I try to use it, the plugin seems to work until I hit the BROWSE button. I then get a 404 ERROR page instead of a list of available images. I tried what Duncan mentioned about typing in the full URL of the browse.php and still get the 404 file not found. Any help would be much appreciated.

Just to clarify, the CKEditor plugin works for all the basics … text formats, lines and happy faces, alignment.

When I try to use the IMAGE PROPERTIES button, I can manually put in the URL and Alternate Text, however, the Browse Server button will only return a 404 error, file not found. I know this must be a setting somewhere but I am at wits end to find it. Anyone with knowledge of this and how I go about making it work, your assistance would be much appreciated.

@Dougster Did you follow-up my suggestion about looking at the web server logs?

I can’t find any logs written at the time the error occurs. Can you tell me which logs to look into?

In the ERROR_LOG, it say Client denied by server configuration … browse.php referrer has a URL with a ? but no PHP file. Is this a misconfigured .htaccess file per chance? And where do I find the default .htaccess files for the folders?

@Dougster There are .htaccess files in the lists, lists/admin and lists/admin/plugins/CKEditorPlugin/kcfinder directories.

@Dougster There is something wrong with the .htaccess files, as I can browse to this URL

That should be disallowed. On my site I get a popup “You don’t have permissions to browse server”.

I’m confused as to why that is happening. I see all the .htaccess files but they all seem to deny access. Should I try downloading the phplist latest version again and copy the whole admin section in?

OK … try that now. I think somehow the baseline .htaccess file wasn’t getting updated. Now, I have it totally updated and it seems to work correctly. Thanks again and sorry for being so hair brained.