back to phpList.org

CKEditor - unable to configure

I’m unable to get CKEditor to load a custom config file. I’ve seen another post about this but don’t think it applies. I edited CKEditorPlugin.php to print on screen the config path and the result of file_exists(), passing it $ckConfigPath (after that’s been set). It looked okay but nothing in my ckconfig.js is having any effect.

I also tried changing “Width in px of CKeditor Area” in Config|Settings to 300 but the editor width did not change (in case there’s a minimum I also tried 500).

I’ve tried logging out, restarting my browser, waiting for the PHP session to terminate, using a different browser but no luck so far.

It’s probably something simple but I can’t see it so far. Any ideas?

Dave

@DR2056

How about showing the value?

Use the developer tools or similar in your browser to see the http requests made when you load the compose page. That should show whether the correct URL is being used and whether it is being found.

Thanks Duncan, I did display the config path value and thought it looked okay but when I used the developer tools, thanks for the suggestion, I saw that it was failing to load ckconfig.js. I hadn’t realised that the web site’s root URL would be added at the front of the path. I’m on a 1&1 server and the actual htdocs root comes after a load of other stuff (/kunden/homepages/20/d…), this wasn’t needed when the root URL comes first.

However… although I can now see that the ckconfig.js is being read still I’m not seeing any styles being added to the Styles drop-down. I’m using the sample ckconfig.js with a couple more styles of my own added. I logged out and back in and restarted Chrome.

The superscript and subscript buttons, which the sample config removes, are also still on the toolbar.

Is there something else I’m missing?

You might need to force a reload of that URL. ctrl F5 usually reloads the page.

Yup, that was it. Many thanks Duncan!