phpList.org

Captcha plugin keeps throwing error

Hi all,

I installed the Captcha plugin in a while ago, and thought I had tested it and verified that it was working. But I think that it has been failing user-entries for a while now. I have just tested it myself and I couldn’t get it to allow me to sign up - I tried 15+ times.

I am pretty darn sure that I am getting the text correct…here’s one example:

Screen Shot 2020-11-18 at 15.08.35

• Running v3.5.8 of PHPList.
• Captcha plugin is v 2.14; plugin documentation page says it was last update back in 2016.

Any troubleshooting suggestions?

Thanks,
J

@J8334SWC Most likely you need to make a small change to the Securimage code due to a recent change in phplist, see https://resources.phplist.com/plugin/captcha#change_to_the_securimage_code

This is wrong. The phplist plugins page will show the installed version and whether an update is available. I will remove this line from the documentation page as it is unnecessary.

Hi Duncan,

Thanks for the response.

Just some more detail on the steps I went through: The PHPList admin page says that this plugin must be updated manually (see screenshot). It reported my current version # 2.1.4. I wasn’t sure how to manually update it, so went to the Plugin Page linked from this admin page, and saw the ‘Last updated…’ date.

Hi Duncan,

Thanks for the link. But it gave me an error when I tried to follow it - unable to connect.

@J8334SWC the link is working now. The plugin is now included with phplist so you will have the latest version.

Thanks for the tips, Duncan. I applied the PHP change and now it is working again!

When you say that it is ‘included in PHPList’… does that mean it’s not a Plugin anymore? My PHPList is set for auto-update, and it has updated rather recently. Would that mean that the Captcha Plugin should have also updated, and perhaps should have already had this change in the PHP in place? I’m wondering if I will have to update the Captcha PHP every time PHPList itself updates.

Thanks,
J

@J8334SWC The change is to the Securimage package, not phplist or the plugin. You would originally have downloaded and installed Securimage separately to phplist. It should not be affected by an update to phplist. So you should need to make the code change only once.

Thanks for the clarification. It makes more sense now. :slight_smile:

1 Like

I am also having this issue, does someone have any solution for this? kindly share your views, thanks in advance!