Campaign list and subscriber list disappeared after upgrade to 3.3.1

I have been running 3.2.7 with reasonable success over the past 3 months with about 3 dozen campaigns sent to just over 100 subscribers each. I used Softaculous Apps Installer to install my earlier version (3.2.7).

Mid-February, the Softaculous section of my cPanel showed that an upgrade available for phpList. I selected the upgrade and asked for it to be installed. All indications were that the installation worked … until I opened phpList and it still showed version 3.2.7 and recommended that I upgrade as soon as possible. The opportunity to upgrade through Softaculous no longer appeared, so I downloaded and installed it. Now, when I access the new 3.3.1, my subscriber lists no longer exist and two new lists have appeared: “test” and “newsletter”, each of which contains only 1 listing – the e-mail address I used during installation. I assume this is an installation default.

I have modified the config.php file to show the same " $database_name " as was used for the 3.2.7 installation, along with the same " $database_user " and " $database_password ".

I retained the 3.2.7 version on the server with a different directory name (as a “just in case” measure). When I access the 3.2.7 version both subscribers and campaigns are shown; however, none of them is available in 3.3.1.

How can I link the new 3.3.1 version to my previous campaigns and subscribers?

you might want to ask softaculous how they do an upgrade.

However, it sounds like you are not looking at the same database… it could be the the ‘table prefix’ is different between the new install and the old install.

Compare your config.php files… the working settings are in the old config.php file.

Thank you, Dan.

My immediate thought was that I had made an error when I identified the database when I set up the 3.3.1 installation – so I double checked that. I think they’re the same, but I’ve included each one just in case my proofreading isn’t what it should be.

The 3.2.7 Config.php file (the one that locates my lists) includes:
# what is your Mysql database server
$database_host = ‘localhost’;

    # what is the name of the database we are using
    $database_name = 'eodadmin_phpli62';

    # who do we log in as?
    $database_user = 'eodadmin_phpli62';

    # and what password do we use
    $database_password = 'PASSWORD';

    The 3.3.1 Config.php file (the one that does NOT locate my lists) includes:
    // what is your Mysql database server hostname
    $database_host = 'localhost';

    // what is the name of the database we are using
    $database_name = 'eodadmin_phpli62';

    // what user has access to this database
    $database_user = 'eodadmin_phpli62';

    // and what is the password to login to control the database
    $database_password = 'PASSWORD';

    The old, 3.2.7 config file (the one that DOES work) contains these statements that are NOT present in the non-working 3.3.1 file:

    # the mysql server port number if not the default
    $database_port = null;

    # the socket to be used
    $database_socket = null;

    # enable database connection compression
    $database_connection_compression = false;

    # force database connection to use SSL
    $database_connection_ssl = false;

    # if you use multiple installations of phpList you can set this to
    # something to identify this one. it will be prepended to email report
    # subjects
    $installation_name = 'eoDanceBulletins';

    # if you want a prefix to all your tables, specify it here,
    $table_prefix = 'plqp_';

    # if you want to use a different prefix to user tables, specify it here.
    # read README.usertables for more information
    $usertable_prefix = 'plqp_user_';

    # if you change the path to the phpList system, make the change here as well
    # path should be relative to the root directory of your webserver (document root)
    $pageroot = '/phplist';

All of that to ask:

  1. can you see any errors I’ve made in setting up the database, etc.?
  2. is any of those additional files from the old config. file necessary and likely to be related to my problem?

Thank you again for your help … I suspect it’s something very tiny … but large enough to prevent the new installation from working.

While I’m still not sure of the source of my problem, I did manage to resolve it. I removed the config.php file (that was generated when installing 3.3.1 and that I modified by copying elements of the 3.2.7 file) and inserted the entire config.php file from the former 3.2.7 version.

Despite a number of cautions against just using the old config file, out of desperation I tried that approach and it works beautifully!

Thanks to answers I got and thanks to any others who have been thinking about the issue.