Broken images and CSS on Subscriber Pages


Images are broken on subscriber pages.

This code is from the admin section and looks fine:

I viewed the source code for the front end subscribe page in firefox. This messed up causing the style sheet and images to break:

Subscribe to our Newsletters

example of code

Can you offer assistance?



Sure would love a response to this challenge


Hi, can you paste your code using the code tag </> - the image is not easy to read.

This code is from the admin section and looks fine:

 <TD align=center colSpan=2 rowspan="2" height="63" bgcolor="#462F1D"><center><a href="" target="_blank"><img src="" border=0 width=577 height=167></a></center></TD>

I viewed the source code for the front end subscribe page in firefox. This is messed up causing the style sheet and images to break:

<TD align=center colSpan=2 rowspan=\"2\" height=\"63\" bgcolor=\"#462F1D\"><center><a href=\"\" target=\"_blank\"><img src=\"\" border=0 width=577 height=167></a></center></TD>
Subscribe to our Newsletters

Hi, I am sorry I don’t know the answer to your question, I have never seen anything like this before. Can you link us to the actual url?

Here is the link

Thanks for your assistance!


Well, my first advise is to see if it worked/s without any of the design changes you have made. It would be good to asses where the problem stems from. Can you restore default somehow? If the default designs do not work then we know the issue is nothing to do with the html, but something else all together.

Hello Anna

Thank you for the response.

I am challenged when it comes to this area. I am not sure how I could go about restoring settings to default. Your thoughts?


humm, well maybe you can get them from the demo here

user admin
password phplist

Many quotes for attribute values are escaped like this: rowspan=“2”

Removing all the backslashes should correct the issue: rowspan=“2”

1 Like


Thanks for the information.

What file(s) would I make these changes?


Can you tell me what files I need to alter?


I think that you have entered this html in either the Settings page “header of public pages” field or on the “header” field on a specific subscribe page. It looks like there is a problem with the php setting for magic_quotes.

I see that you are using phplist 3.0.9 so you must have either had the problem for a while and not noticed or it has suddenly started happening, so please can you explain the background to the problem.

You can get the default values for “header of public pages” and “footer of public pages” by logging-in to the demo system and going to the Settings page. Then copy/paste the html into your phplist.

Ignore my previous post.

There was a bug introduced in release 3.0.9 that caused your problem
You should upgrade to the latest release of phplist. After that you then might have to edit the header of public pages value to remove the erroneous \ characters.

1 Like

Hi Paul

thought I’d have a play and try to replicate your problem on an alternate subscibe page on my site, my main subscribe page looks like

however as I spent only 5 minutes trying to create your issues I could only come up with a web page that looks like

Your Subscribe page

though my version does include several options including the AGP Capture and responsive forms hence the non alignment of the fields. I’ll continue to have a play, though as Duncan has said upgrading to the latest version would be a good idea.

Kind regards


1 Like


I spent a lot of time trying to figure this out but I am so lost.

I am running 3.0.9 so I don’t understand how I can upgrade to something I already have. The code in the header of in the back end does not have the \ characters present but it does show up when I view code from the front end in the browser.

Sorry for the confusion


I explained that a problem was introduced into release 3.0.9, so you need to upgrade to a later release of phplist. The current release is 3.0.12.

1 Like

Hey @webpowermail did you get to upgrade? Is your issue solved?

Sadly, it is still an issue.

Thanks for checking in!

Did you upgrade though?