Blank page on installation

Hy everyone, I’m new on this blog but you are very skilled so, I guess someone could help me …
I have a standalone MAMP installation on my mac with phplist 3.2.4 and Safari as browser.
I have putted lists on root directory and created a new database named phplist.
I have modified config.php as requested but when I link to the page localhost/lists/admin nothing happens
I only have a blank page, no error messages or other things.
can someone tell me what could be happened?
many thank to all

This issue usually means you’ve missed a quote (single or double) or a semi-colon at the end of a line when you’ve been altering the config.php file. all php files are VERY sensitive to this.

Look at the config file again, check all the lines you’ve altered, see that if the value= lines have a single quote, and make sure that they have a matching single quote, and semi-colon (:wink: at the end, or if they start with a double quote, that the end with a matching double quote (").

Also, if you’ve put a quote in for example a password entry it won’t work. Hopefully this will give you a head start?

Hi, and many many thanks to your reply…
I’ve double checked the quotes but it’s seems everything all right
I copy some of the text changed in my config.php


# what is your Mysql database server hostname
$database_host = 'localhost';

# what is the name of the database we are using
$database_name = 'phplist';

# what user has access to this database
$database_user = 'phplist';

# and what is the password to login to control the database
$database_password = 'phplist';

# if you have an SMTP server, set it here. Otherwise it will use the normal php mail() function
## if your SMTP server is called "" you enter this below like this:
##     define("PHPMAILERHOST",'');

define('PHPMAILERHOST', ‘’);

# if test is true (not 0) it will not actually send ANY messages, but display what it would have sent
# this is here, to make sure you edited the config file and mails are not sent "accidentally"
# on unmanaged systems

define('TEST', 1);


Actually, the username and password aren’t the right one … :smile:

What’s wrong, I guess?
thanks to all

Don’t know if it’s just the way you’ve pasted the above, but from what I can tell, you’ve an extra double quote both at the beginning and end of the pasted text, also you seem to have incorrect single quotes around near the end.

Did you use Word or a plain text editor (never use Word to edit any php file by the way.

1 Like

Hi Dragonrider, thanks to your reply…
I’ve put the double quote to the beginning and the end of the pasted text but in the config.php there isn’t and I’ve checked the single quotes around (is the right one)
I use text edit on my mac (I think it’s a plain text editor cause I use it for other purposes where it’s necessary a plain text and everything goes well)

I continue to have the same problem … :frowning:
I’m crashing my head into angles walls … :smile:

I’ve tried to launch the page on firefox but … same result …

I’m desperate, may be a fishing week end will help …
please help !
Many thanks

Trouble is, with it being a local (to your computer) installation it’s a bit difficult to have a look at it for you.

It is possible however, if you really need it though, let me know.

Normally a blank screen/page does mean there is a syntax error in a php file, have you changed any other files, in addition to the config.php file?

You might want to just try an ‘unchanged’ config.php file. At least the web interface to phpList will say that it cannot connect to the database.

Once that is working (you see the ‘cannot connect to database’ page), you know that the install is working enough to produce that page.

Then, in the config.php file, change the database settings (if you are on a pc, use notepad, or notepad++)

Just change the database settings in the config.php file. Once the database settings are properly configured, the system will go to the ‘initialize database’ page.

Then you’re past the blank page problem.