Best practices: do *not* send unsubscribe confirmation email

As written about in the following link, email campaigners get better delivery and less spam listing if they don’t send confirmation emails after a subscriber unsubscribes. See the following article.

Why can’t such a feature work in phplist? All of the methods suggested in forums either do not work, or in the process of working, remove the sending of other important administrative emails.

Excerpt form the tech note:

“. . . over time it will affect your reputation and deliverability.”

Read all about it here:

Not used this myself, but reading the instructions in the config_extended file, if you set the blacklist_gracetime to 1, this will probably stop an unsubscribe message being sent.

# when a user unsubscribes they are sent one final email informing them of
# their unsubscription. In order for that email to actually go out, a gracetime
# needs to be set otherwise it will never go out. The default of 5 minutes should
# be fine, but you can increase it if you experience problems
$blacklist_gracetime = 5;

Using this method should avoid hav ing to make changes to the core code on later updates I would think.

Old post, but this info might still be useful to people (it was for me! I just got yelled at by a user who unsubscribed and was pissed about getting an email confirmation):

In config:

// To not send confirmation of unsubscription , instead of
// the default way, which will send it, set this to false

Interesting, so their, and your, preference is to unsubscribe and send no confirmation of any sort? Note the confirmation is just a courtesy, it doesn’t require action afaicr.

Yes and yes. And I unsubscribe from newsletters regularly, and I’d go so far as to say I never receive an email confirmation in response. As you probably know, people are really sensitive about email, and I think when people unsubscribe they are telling us “I don’t want to hear from you again!” And to immediately hear from us again via the confirmation email is considered an annoyance.

As a first time phplist user (who is currently sending out an email to my 7,700 users, and it’s going well! Thanks for the great tool), I did not expect this to be default behavior. And furthermore, I expected to be able to toggle this setting in Settings, and not in Config. But that’s just me, and I figured it out.

1 Like

Thanks, that’s helpful. Disabling the notification by default should be as simple as reducing the default grace time, then. This is something for @suela to consider for future releases.