Behind Redirecting Nginx : The pageroot in your config does not match the current location

i got the error message that “The pageroot in your config “/wp/lists” does not match the current location “/lists”. Check your config file.” Phplist is in a docker container with wordpress in the local root, so there the path /lists is right, but the hole container is redirected under a subdirectory with So the right pageroot is With the config setting pageroot it’s working, but i got the error message. I tried to re-build the hole database, for fresh installation, but its still there.

@tegg What is the result of setting $pageroot to '/lists' ?

when i change a setting and click save, it ends on the main domain without /wp
the same ist with the links in the footer. They have the right form, but ends on

@tegg I’m still unclear how this structure is meant to work.
To access phplist the URL is
To access wordpress the URL is or simply ?

$pageroot is used when phplist constructs a URL to itself. It should reflect the path from the web root. Possibly the web root is not being set correctly.
phplist constructs the URL using the “web site” from the Settings page and $pageroot, e.g.

$viewurl = $GLOBALS['public_scheme'].'://'.$website.$GLOBALS['pageroot'].'/dl.php?id='.$att['id'];

You can disable this warning by adding this to config.php

define('WARN_ABOUT_PHP_SETTINGS', false);

But I would then expect those URLs constructed by phplist to be

there is a docker container, with a nginx on port 80/443 for the domain. In nginx is a proxy_pass for domain/wp to (org as example is no more allowed :smiley: ) internal Port 8080, there is an apache with wordpress and phplist. So the hostname:port in apache is the IP

without pageroot i got a wrong directing on some button, like new message. Without pageroot i landing on domain, without /wp/lists. Maybe there is a better configuration possible for this special constellation, there were also Problem with wordpress and i have to set http_host, server_port and https manually

What do you mean by this? $pageroot must be set to something, you must not leave it empty. I would expect '/lists' to work.

pageroot is ‘optional’ in the config_extended, isn’t it ? So i assumed that you don’t have to set it. With pageroot=’/lists’ i got the same error, like without, with new message i got the requested URL is https://domain/lists/admin/?page not https://domain/wp/lists/admin/?page, so i end on the main page

with pageroot=’/wp/lists’ the redirect link is still not correct. It http://domain/wp/lists instead of https:// domain/wp/lists. So the same problem as with wordpress. How could i correct this ?

EDIT: the https Problem is solved with $_SERVER[‘HTTPS’] = ‘on’;
$_SERVER[‘SERVER_PORT’] = 443; in the config.php, but $_SERVER[‘HTTP_HOST’] is not working