back to phpList.org

Automatic character masking


#1

Hi,

this is my first post on phpList.

I’ve got a problem which persists since I first started using phpList in 2014. When I compose a message, save it and then reopen it (or jump to the next tab), any special characters like quotation marks automatically get masked with a backslash. This continues to happen, as the backslash itself gets masked too at the next save. this results in code that looks like:

<div class=\"footer\" style=\"text-align:left; font-size: 75%;\">
<table style=\"width:631px;\">

The next save will convert it to:

<div class=\\\"footer\\\" style=\\\"text-align:left; font-size: 75%;\\\">
<table style=\\\"width:631px;\\\">

In effect, this makes all my links unusable in composing a message. Has anyone got an idea what causes this and how to remove this behaviour?

I am using phpList 3.3.4 and the german language pack.

Thanks a lot!
Hans


#2

Perhaps this post offers a solution?


#3

It might be a mistake in the CSS main file. Check it.


#4

@Dragonrider Thank you! The main idea of the post was updating to the latest version which I have done, but unfortunately that doesn’t change anything.
@Leesajohnson Thank you! I did a clean install on a different directory on my website and the issue remains the same, so I guess that it might have to do with some server settings on my hosts end. I am pursuing this lead for now, but I am grateful for any ideas.


#5

Can you clarify how you are creating the message? I am using CKeditor, and don’t have the problem. The CKEditor version is 2.1.2+20160514.

I’m also using the English version.

So things to check are:

  1. to update/verify the version of your CKEditor.

  2. change to the English language pack (via your config.php file) and see if that makes any difference.

If neither of those work, then it’s your OS that might need to be looked at. What is the OS and version of your server, and what version of php is installed on it? You can find the php version via the “Common Plugin”.

Dan


#6

Hi @danwaterloo thank you!
I am using CKEditorPlugin 2.1.3+20160603
I have used the most recent version that came bundled with phpList 3.3.4.

  • Changed the config file from german.inc to english.inc: still the same behaviour
  • My server is an apache and the php version is 5.3 latest stable GnuTls. Right now I am changing it to php 7.2 and see if that does anything.However, there is a wait time of up to an hour until the changes are live.

edit
Updating to PHP 7.2 seems to do the trick! Thank you guys for contributing and @danwaterloo for the correct guess!