back to phpList.org

"Access denied" browsing the upload directory with fckeditor but access with CKEditor and with TineMCE

Getting kind of confused. I’m still using and like a lot the FCKEditor. I always needed to exchange the .htaccess file in the admin/plugin/ directory after a manually update. Not anymore after switching to automatic updates.

I didn’t use phplist for some month’s (because all events were cancelled).

I just updated automatically to 3.5.6. Now I can’t access the upload directory. I tried all kind of things (updating the plugins, switched to CKEditor, changed the htaccess files, reinstalled everything - plugins + main). Went through all the topics here and tried all the solutions. A direct upload into the upload directory is no problem (with FCKEditor) but browsing is impossilble with the error “Access denied”.

Funny enough I’ve had no problem with the elfinder of TinyMCE. In CKEditor I didn’t see anything (empty window) and didn’t get an error. After doing all kind of installing, reinstalling etc. I could access the upload directory finally. The upload directory didn’t change.

Any idea what might be wrong in my case?
All of the latest versions (main core + plugins) are installed. PHP 7.2 is running on the server (+ Apache 2.4)

@srberlin phplist In release 3.5.5 changed the php session name. While the CKEditor plugin was updated to use that new session name I don’t think that the fckeditor was updated which would probably account for “access denied”.

The file browsing in the ckeditor plugin should work but you need to update the ckeditor plugin as explained at Cannot Browse Server After upgrading to 3.5.5

Thanks a lot for your answer.The CKEditor was finally working. I did everything that was explained here and maybe even more.

My problem was and still is the fckeditor. And I prefer this editor. I hope they will update it (but actually don’t think that this will happen).

I guess I should just get used to CKEditor… :wink: