3.2.0 Upgrade 500 internal server error

Hey guys - just upgraded to 3.2.0 from - I dunno - 3.0? it had been a while…

now I’m getting a 500 error on /lists and lists/admin and I have no idea why - googled around, searched the old forum and this, read the trouble shooting, nothing other than possibly removing lines from .htaccess or even removing .htaccess altogether was mentioned… I tried both of those (actually the magic quotes line wasn’t in my .htaccess)…

still getting 500 error - permissions seem to be all right - sort of stuck…

thanks! :slight_smile:

error 500 is an apache error, look here


Make sure your mysql logins are correct, and that you are using this in your config.php:

# select the database module to use
# anyone wanting to submit other database modules is
# very welcome!
$database_module = "mysqli.inc";

Did your upgraded installation ever work, ie: did it work then it stopped working?
Are you on Lunarpages hosting? I ask as I’ve got this error myself and it’s due to some server upgrades where to solve it I had to change the password for my MySQL databases. (You can change the password to the existing password on LP, it just needs to recode (?) the password bits or something.

Might be worth changing your password anyway, in case your host has updated it’s server recently.

Not sure this host is running apache or not… Although what the hell else would be doing? MySQL info is right… But… Post below says to try changing its pword… Might as well try…

Tried everything in those and other posts… To no avail… Hmm

Icdsoft…not lunarpages… But I guess I might as well try the MySQL pword change… Hmmmm! :slight_smile:

Oh… No it never worked. The previous install worked though :slight_smile:

Any clues in the server error logs?

Well…hmm I don’t control the server…it’s just a hosting account. Dunno if I can even get at the logs. (No she’ll access or anything). Hmm maybe I’ll get with their support

I too only have a hosted account, but with LP there is full access to several logs, including the vital Error Logs.

Ahh, just had a look at your host’s help pages, you’ll have to ask them for info on what error is being shown

Note that the error_log of the web server is not available. The mail
logs are not available either. If you need information from these logs,
please contact our support team.

Thanks for checking that out for me Dragonrider!

So I went in and I created a separate DB for lists, moved the phplist tables and changed the password - I did this because I couldn’t just change up my main DB password with out wreaking havoc in other apps and web stuff - so bam.

That worked! No more 500 error. So - now it’s telling me to upgrade to 3.2.1 lol - which I’ll probably try…wish me luck! and then there’s some more work to do because I’m going to try to get an autoresponder up and running…

wish me more luck! and thanks again!

– Aaron

This is just a minor version, you don’t really need to if you are worried :smile:

Lol thanks. It worked fine. Installed autoresponder which thus far seems to be working.

Wish me more luck. This is me trying to do what aweber or constant contact do myself, so I can save what could be a significant amount of money, depending on the growth of the list! :slight_smile:

1 Like

Well, if you struggle, try phpList.com. It’s cheaper than CC for sure :wink:

heh I’m doing pretty good so far - and now I’m replying… a weird issue with Autoresponder - suddenly it’s not able to see my lists or my drafts - thus I can’t create an autoresponder - although at one point I DID create one - now no - both on a new install and the original install…

hmmm - any thoughts anybody? :smile:

  • A

oh - nevermind but - let me put this here for others - this is about AUTORESPONDER…

first you have to create a draft (did that)
you MUST select a LIST for the draft - otherwise autoresponder won’t find it - this also appears to be how autoresponder knows which list someone subscribes to in order to get that autoresponder going

also - it won’t see lists in the filter section unless there are available draft messages for that list…I THINK…

I’ve just updated my test version of phpList to 3.2.2 and hit the same dreaded Error 500 problem. Took me a while to remember that I hadn’t re-uploaded the saved config.php file from before I uploaded the new files. Once I re-instated the original config file, everything works fine.

So if you’ve got the same problem, that’s another option for you to try.

1 Like

Hi, just say thanks to Dragonrider. I’m on a dedicated and just upgraded server in Lunarpages and turned me crazy with 500 error. Play too much with .htaccess and php.ini is insane.
Just change BD user password and phplist works again!