10000 emails per batch limit


I’m getting the following message when attempting to send 10,000+ emails at single batch.

Less than batch size were sent, so reloading imminently
In the last 3600 seconds more emails were sent (10000) than is currently allowed per batch (10000)
Script stage: 5
Finished, Nothing to do

I run default settings:


I was under impression that if you have MAILQUEUE_BATCH_SIZE set to 0, there is no throttling. That seems not to be the case. Is there a hard limit of 10,000 emails per single batch?

The batch size of 10,000 applies when you process the queue through the browser. If you use a cron job to process the queue then a batch size of 0 is allowed.

Thanks for your explanation, is there a way to disable this behavior? I did not have that problem with previous version (2.x)

I don’t think so, see this explanation on Mantis. But you could try changing the batch period to be much smaller. That should reduce the time between batches.

Trouble is I cannot test it, well at least when I use TEST MODE it throttles it even more for some bizarre reason according to the report: 4624 msgs/hr

9611 still to process
ETA: Fri 22 May 11:10
processing 4624 msgs/hr

When in “LIVE” mode, sending 10,000 emails takes around 5-10min, which would contradict the TEST MODE even with the same settings. I changed the batch period value to 100 and the processing estimate show 2465 msgs/hr.

I guess I’m going to have to wait for another opportunity to “live” test batch period set value to 100 as I see no consistency between LIVE and TEST MODE.