back to phpList.org

Wrong number of mails sent appearing in list of campaigns


#1

Hello,

We are using an installation of v3.3.1 which has been migrated from a different server and upgraded.

We notice that in this installation, the number of messages sent is falsely reported on the “List of Campaigns” page.

As an example, here is what the List of Campaigns shows in contrast to the stats page:

Note that the detailed stats page also shows the wrong number as “Sent as HTML”.

I have confirmed from the mail server stats that the real number of mails sent was ~4K on these cases and not 9.3K or 37.7K.

What may be wrong? How can we correct phplist to display correct numbers?

Please advise!

Thanks,
Nick


#2

@Appletech The large figure on the Campaigns page is the number of attempts to send so I guess that you had a very large number of errors when sending. Possibly the send rate is too high.

Look at the event log page to see if anything has been reported there.


#3

Thank you for the reply.

Our phplist application is on a web server connecting to the mail server on port 587 using TLS in order to submit mails. If I understand your comments right, then the phplist application on the web server tries too often to connect and these connections fail.

My phplist settings currently are:

define("MAILQUEUE_BATCH_SIZE",300);
define("MAILQUEUE_BATCH_PERIOD",600);
define('MAILQUEUE_THROTTLE',1);

define('USE_DOMAIN_THROTTLE',1);
define('DOMAIN_BATCH_SIZE',50);
define('DOMAIN_BATCH_PERIOD',300);
define('DOMAIN_AUTO_THROTTLE',1);

Will you please advise me whether there are any conflicts or other issues with the above?

What should I try to change, based on your experience?

Thanks in advance,
Nick


#4

Have you looked at the event log page?


#5

Here is an excerpt from the event log, which keeps on logging endlessly like that:

Any ideas?

Thanks,
Nick


#6

Hmm, I understand the above log excerpt I posted is irrelevant…

I scrolled back to a campaign submission log and found that the “problem” seems to have been domain throttling and that affects our own domain!

noa.gr is currently over throttle limit of 50 per 300 seconds (50) 

I decided I should disable domain throttling, and we’ll see how it goes, when a new campaign is submitted.

I’ll let you know!

Thanks,
Nick


#7

@Appletech The config.php settings that you showed will send 300 emails at 1s intervals, so 300 emails in about 400s, which is much more than you are allowed.

Domain throttle will slow that down but it looks like the rate is still too fast. You need to change the batch size and batch period to meet the restriction.

The event log messages are caused by you having VERBOSE enabled in config.php. You should turn that off as the volume of event log messages swamps other more important messages.


#8

If I set:

define("MAILQUEUE_BATCH_SIZE",300);
define("MAILQUEUE_BATCH_PERIOD",600);
define('MAILQUEUE_THROTTLE',0);
define('MAILQUEUE_AUTOTHROTTLE',1);

define('USE_DOMAIN_THROTTLE',0);
define('DOMAIN_BATCH_SIZE',300);
define('DOMAIN_BATCH_PERIOD',600);
define('DOMAIN_AUTO_THROTTLE',1);

does that seem workable/sensible?

(I have also removed the VERBOSE logging option, thanks.)

Nick


#9

By the way, wouldn’t it be better to name this number something like “Attempted Submission Connections” rather than “Sent as HTML”?

All the best,
Nick


#10

@Appletech In the development version of phpList (which will become phpList 3.3.2) the stats are labelled differently, partly in order to clarify what you describe. The table containing the confusing statistic is now titled ‘Processed’ (because processing attempts are not the same as messages sent). See screenshot.


#11

Your limit is 50 emails within 300s but these settings say to send 300 emails in 600s.