Why is my "Send A Campaign" page appearing blank?

Greetings. I am fairly new to using PHPlist and apologize for having to call upon the generosity of those more PHPlist-savvy than myself to overcome these obstacles I’ve encountered. I’ve read the PHPlist manual and searched the forum but am still stumped by two things. I’ll put the other issue in a separate post for organization’s sake, but here’s my first issue:

When I’m logged into PHPlist (version 3.0.12, in Mac OS 10.8.5 using Safari 6.2.6 or Firefox 39.0) most of the pages in PHPlist appear just fine. But when I hover over the Campaigns menu tab and select Send A Campaign, my browser displays the new page for a fraction of a second before it disappears and I’m left with a blank web page. And when I say blank, I do mean blank—there’s nothing in the browser window. I’ve also tried navigating to the Send A Campaign page from the Dashboard page, but that produces the same result. I wondered if it was trouble with the Web browser or operating system, so I tried it in two different browsers on my Mac as well as Internet Explorer in Windows 7 and get the same result: a blank page. Thus, I’m unable to create or send a campaign.

Any help would be much appreciated.

I’ve seen this happen with servers running PHP 5.4.1
What version are you running?

Thanks, NYChris!

I inquired about this with my Web hosting provider and they said my domain currently runs PHP Version 5.3.29. They also said that I could select the PHP version I want to run on each directory of my domain…screenshot at https://www.dropbox.com/s/gxcvaqdpp2vrzbc/ntPHP%20Selector.png?dl=0

I see that I can select from PHP 5.2, 5.3, 5.4, or 5.5. I imagine I should select the public_html directory for PHPList? https://www.dropbox.com/s/ovp1m2wyg4a765o/public_html%20PHP.png?dl=0

Any suggestions for what PHP version to select for better compatibility with PHPList?


I wish I had an answer for you.
5.3 has reached “End of Life”.
5.4 is just about at “EOL”.
Most of my servers are running 5.5

The only time I witnessed this anomaly was on one server running PHP 5.4.1 and I have no idea if it’s even relevant to the issue.

That’s quite OK. At least this has given me a possibility to examine. Thank you very much!

One possible cause is having the wrong value for $pageroot in your config.php file

# if you change the path to the phpList system, make the change here as well
# path should be relative to the root directory of your webserver (document root)
$pageroot = '/lists';

Thanks very much, Duncanc! Your tip prompted me to uninstall and reinstall phpList, which seems to have resolved this problem. I appreciate the generous assistance! :smile:

1 Like