Very slow throttling not possible

We need to send very few emails out per day and struggle with the throttling settings.

We have six different emails (campaigns) that need to be sent out.
Let’s say we would like to send out one (1) email every 10 hours. So now one email of campaign 1, in 10 hours one email of campaign 2, 10 hours later one email of campaign 3, etc.

the config.php looks as follows:

Once the queue starts processing, it only takes like 45-60 minutes before email two gets sent out. So the “Autothrottle” is not waiting 10 hours, to send out the next email. Also the following emails get send out after 45-60 minutes, so after 6 hours the whole batch is done.

Even if we use “manual” throttle, like this:

it doesn’t work. Again, the break between two emails is around 60 minutes, instead of 10 hours. There must be some sort of “maximum” value defined somewhere.

I do understand, that it doesn’t really make sense for a newsletter tool to send out an email every 10 hours, but the specific use case we have requires exactly that. Is there a setting anywhere in the code, where we could modify that?

Did you find a solution to this yet? It seems that the documentation around queue throttling could be improved (feel free to edit it directly on the wiki or GitHub).

No I didn’t find a solution yet. I don’t understand enough PHP to be able to edit the documentation I’m afraid.

@overeyed No PHP required; just registration here:

It has an interactive editor (like wordpress) or a text-based editor, as you prefer.

@overeyed You can try enabling VERBOSE in the config.php file. That should cause extra output when phplist is processing the queue, which might throw some light on what is happening.

Also, you haven’t said how you are processing the queue, a cron job or through the browser. It really should be a cron job.

1 Like