UTF bug in special characters


I’m using phplist for a long time and it’s great but recently I noticed that there is an error for portuguese UTF codification.

I will give you an exact example:

This product:
…1179-xarope-barbas-de-milho-xarope-barbas-de-milho-pés-de-cereja-500ml.html (you can see there’s an portuguese special character “é”)

Soo It’s UTF Real URL is:
(notice that the “é” it’s changed by “%C3%A9”)

Your Module converts to this:


So, when some client clic the link he will get a 404 error page.

Can some one help me please?

@jvicente Which release of phplist are you using?
And how do you compose the message - using the phplist editor or by copy/paste from an external editor?

The URL works correctly for me with the latest phplist, 3.2.1, using CKEditor.


I’m using v3.2.1

Usualy I copy/paste from external editor. But the external language it’s ok. I try all the url links and they’re fine. There’s something wrong after copy/past to phplists

In phplist where do you paste the html?

Ok…I start a “New Campaingn” and then in “content” “Compose a message” I click on “source” and paste all the code there

@jvicente Is that fckeditor or ckeditor?
Unless you need to edit the message within phplist, try disabling the editor so that you paste into a text area.

I noticec thar the url links that phplist creates have a tracking redirect like this one that I just copied:

Do you think the bug comes from the lt.php file?

The link still works when click tracking is enabled.
Did you try disabling the editor, and which editor are you using?

I use FCKeditor but I don’t know how to disable it!

Hi…problem solved…I went to the “Config” and then “manage Plugins” and deactivated FCK and activated CKEditor plugin. Created a new campain as I did before and now the url links are ok.

Thanks for the help…

1 Like