back to phpList.org

Upgrade issue plugins


#1

My permissions are the same after upgrading from to 3.4, yet I am getting this error message when I try to view my plugins: “The plugin root directory is not writable, please install plugins manually”

I’ve not seen this happen before, and have been using this over 10 years.


#2

I suspect it has to do with this “problem” which I don’t have because I don’t use suPHP, because PHP-FPM is faster and more secure than suPHP.

  1. Change permissions of the /plugins directory to 755 to improve security and fix compatibility with suPHP — thanks to Duncan for reporting.

#3

I tried changing the permissions of all directories in plugins down to 777, but I still get this error:
“The plugin root directory is not writable, please install plugins manually”


#4

@keeenone Can you show the config file entry that defines the plugin root directory, and a screenshot that shows the directory permissions?

This shows the permissions before the recent change, the plugins directory is writeable by everyone.
image


#5

I found the issue…I had the line set to a backup plugin directory:
define(“PLUGIN_ROOTDIR”,"/lists/admin/plugins-backup");

instead of my main plugin directory:
define(“PLUGIN_ROOTDIR”,"/lists/admin/plugins");

after changing it my plugins now work. I did that, however, because I thought this was the advice that was given to me to make it so that my plugins would not break when I used the new auto updater. That updater breaks all plugins. Now that I’ve set this to the main plugin directory will auto updater not break the plugins on an update?


split this topic #6

A post was split to a new topic: Date format of statistics (US vs EU)


#7

The updater will still remove all non-core plugins during update unfortunately, but it won’t “break” them in the sense that if you install them using the Web interface again then they should work as before, unless you manually patched some files, in which case you’d need to reapply those patches.

FYI probably the updater will further improve its’ handling of plugins in the release next month thanks to @xheni.