back to phpList.org

Update 3.3.7 to 3.3.8


#1

I just did the update from 3.3.7 to 3.3.8.
I used the beta update function.
Two things.
1 he said there was made a backup, but there was no backup in the specified folder
2 I try to send -while making a new message- a test email and the responds is ‘failed’

All the other functions seems to work well.
How can I solve the problem with sending a (test) message. It allways went well.

Fred Prins


#2

Tried the update following the 3.3.8 release e-mail received today.
Got a message “Starting integrity check
The following files are not expected or are required: adminstructure.php”.
Deleted the page (‘next’ greyed out) and started again - got the message: “Updater is loading.
The following files are not expected or are required: adminstructure.php.”
Not a file I’ve either added or removed so not sure what to do next.
Any advice?
Thanks in advance.


#3

A mi me ocurre pero con un archivo que he añadido para una plantilla de email (css_template)
Lo que hace el actualizador automático es comparar los archivos de la instalación y verificar si falta o hay alguno añadido para realizar el backup con éxito y así evitar eliminar archivos que hayan sido añadidos o modificados por el usuario.
Busca el archivo en tu instalación y comprueba si existe o falta; Si el archivo existe prueba a moverlo temporalmente a una carpeta fuera de PHPLIST e intenta realizar el backup de nuevo. Si el archivo no estás tendrás que localizarlo para poner en la carpeta de la instalación PHPLIST que corresponda.
Sería de ayuda que la herramienta de instalación automática de la información del archivo si es por existencia o por demanda.
Saludos


#4

Google translate of the above:

It happens to me but with a file that I added for an email template (css_template)
What the automatic updater does is to compare the files of the installation and verify if there is missing or there is any added to make the backup successfully and thus avoid deleting files that have been added or modified by the user.
Search the file in your installation and check if it exists or is missing; If the file exists try to move it temporarily to a folder outside PHPLIST and try to make the backup again. If the file is not you will have to locate it to put in the folder of the PHPLIST installation that corresponds.
It would be helpful if the automatic installation tool of the file information if it is by existence or by demand.
regards


#5

@ffprins @shaddo @aruiz Thanks for the feedback!


#6

@shaddo Perhaps that file is missing or was renamed - you can check if it exists and has the same permissions as other files. If it’s missing you can add it from another download of your old phpList version. Not sure why that file would have been changed in your copy.


#7

@ffprins

  1. I think the backup is deleted after successful upgrade, but @xheni can confirm
  2. Check the phpList log to see if there are more details. The error message when you send the test simply says “failed”?

#8

@aruiz Agreed. That’s a good feature request for a future release


#9

The file was there and with same permissions as other files. Once I removed it the updater progressed through download but then hung on the installing step. I’m afraid I’m not an expert in these matters so it’s probably best if I wait a few days till my hoster has the latest package and then use his ‘Softaculous’ updater.
Thanks for the prompt response.


#10

No, the error message in the screen is:
“Het verzenden van het testbericht naar: fred.prins@gmail.com is mislukt”.
It’s Dutch and ‘mislukt’ means ‘failed’ (and ‘testbericht’ is ‘message’).
To solve the problem I copied the whole public_html (with Filezilla) into my lists folder in my website (and after that I edited my config.php for good working).
It’s a pitty, the result is:
“Het verzenden van het testbericht naar: fred.prins@gmail.com is mislukt”
It worked well in 3.3.7 and before.
And- as I wrote- the backup function didn’t make a backup.


#11

I re-installed again, made a new test message and now it’s send successfully,
My conclusion: the beta-update function does not work well.
Updating by copying works.
Thanks,
Fred Prins


#12

@shaddo Do you remember if it had the same owner and group owner as the other files as well? Maybe that file was owned by root and the others not. There must have been something different about it.


#13

Yes - it had the same owner. The one thing I noticed was that is was dated 2015, presumably when I did the first installation, whereas all my other files are dated 2018 or later. Don’t know whether this is significant but as the install seemed to proceed after I’d remove it I assume not.
Have tried again having added the adminstructure.php file back in. Installer goes straight to download then shows “the update has been downloaded” but hangs on the install stage.


#14

Now updated OK using host’s Softaculous updater. New dashboard looks great!
Thanks


#15

Sorry to hear that the problem persisted. It’s not yet clear to me what caused it; if you have the same problem next time please report it again. Now that the update was completed by softaculous no further investigation is possible until the next release.


#16

Hi Samtuke. Apologies for going ahead with Softaculous - I did realise that if this worked this would make further diagnosis of the problem impossible but I wasn’t sure I had enough technical expertise ( or time this month!) to be able to help you investigate further. I appreciate your response and will try the updater again on the next release and advise you if I hit any problems.
Many thanks
Gareth