Unknown error after installation PHPList

After installation of php list v3.2.0 I am getting a messages Failed without a clear explanation. It is t possible to create a subscribe page add subscribers or to create a campaign. When creating a campaign the text editor isn’t available

I tried to edit the paths of the plug-ins or disable/enabled a other
text editor but that gives the save error.

Php list is installed under:


what is the url for your site please (if you wish to remain private, just give link from www.domain.com.

what is the url under $pageroot in your lists/config/config.php file?

(Clue: They must match).
By Default phpList assumes you have installed at domain.com/lists if you change this you need to add $pageroot (from config_extended.php) into config.php file.

The path to my domain is /domains/www.domain.com/public_html/lists

I have added $pageroot to config.php and tried 3 settings
$pageroot = ‘/lists’;
$pageroot =‘domain.com/public_html/lists’;
$pageroot = ‘domain.com/lists’;

When installing I had a 500 internal server error so I removed the.htaccess files inside the folders “/lists” en “/admin” could that have anything to do with it?

Is it helpful if I send data auto of the PHP info file?

$pageroot =’/domain.com/public_html/lists’;
$pageroot =’/www.domain.com/public_html/lists’;
or even
$pageroot =’/public_html/lists’;

Regarding your .htaccess files, did they have any php_flag lines in? That’s the “usual” cause of Error 500’s
If so, remove those lines and reinstate the .htaccess files.

1 Like

I have tryed the setting below:
$pageroot =’/domain.com/public_html/lists’;
$pageroot =’/www.domain.com/public_html/lists’;
$pageroot =’/public_html/lists’;

I don’t think that the problem is the fckphplist plug-in, the editor is displayed correctly.
But it is not possible to save any data, when I type a subjectline the data gets lost on saving.
I have check the database settings and every thing has a green thumb

The problem of the Error 500 is solved, there where no php_flag lines


If the page that you end up with when you type:
ends up in your file system at

then… you should have this in your config.php:
$pageroot = ‘/’;


Everything works now, without deleting the .htacces files or addition the $pageroot.
I looks like the problem was on the server.
It took the sever some time to pickup the changes in the config.php +30min

1 Like