Unable to install AmazonSES plugin on latest PHPList

Hello, I have JUST installed PHP (through Softaculos) on my shared hosting (PHP 7.2, MySQL, cPanel).
PHPList version is 3.5.3
I wanted to use it with AmazonAWS so I installed the AmazonSES plugin (version 1.3.1+20200415). It installed correctly but there is no option to enable it and at the bottom of the plugin it says:

Dependency check: Plugin can not be enabled.
Failure on system requirement Common Plugin version 3.12.0 or later installed

Does this mean the plugin is not compatible with the latest version of PHPList i just installed? Or something else?
Appreciate any help.
Thank you

It just means exactly what it says, the Common Plugin is required.

You need to also install the common plugin. It provides features that the amazon ses plugin needs to work

Thank you VERY MUCH for the fast reply and for pointing me in the right direction!

I must say the wording could have been a little bit more obvious: “Common Plugin or later installed” isn’t a very clear way to say “You need to install the Common Plugin” and if one doesn’t know there is such a thing as a Common Plugin it makes even less sense :wink:
But thanks for explaining!