Style seems to have disappeared on update / fresh install

Hi everyone , a (very occasional ) user of PHPList since 2006. I recently went to send a newsletter and was promoted to update ( i am on 3.0.5 was told to upgrade to 3.3.1…) so i went to upgrade, following instructions, and while the upgrade seems to have worked functionally, the admin interface styling has completely disappeared… i have a basic non styled interface…no images, no formatting etc… I thought perhaps i had screwed up something so i uninstalled a new version ( both by manual installation and also via Cpanel install via Softaculous…) and even in these clean installs the styling seems to have disappeared.

When I revert to using the 3.0.5 backup, i get a nice , user friendly Admin area.

( i user a folder called /mail2/ rather than /lists/ for my main phplist installation, however i dont think this should impact, i have it declared in my config file)

Am I missing something? is the admin section meant to be " style free"?) why has the CSS disappeared? is this supposed to happen or something weird going on?
thanks for any help!


What theme are you using? There’s a couple now.

It’s in the Config>Settings page, under General Settings, look for the Theme option. dressprow is the cleanest, (to me anyway), then there’s Trevelin which if I choose, my installation seems to go to phplist-ui-bootlist instead!

Hi Dragonrider thanks for your reply

I was not aware that I needed to apply a theme to Phplist. it seems strange that a brand new install from softabulous would not be pre-configured for one of the themes?

indeed i cannot see where i am supposed to select the theme if you mean from within the Settings page in Admin ( i dont see any reference to Theme on this page…)

Is this is the page you are reffering to:


or is this a setting that i am supposed to make within the config.php file?

@conor71 See this earlier topic for a similar problem with the theme not being applied after an upgrade CSS/Theme support broken after upgrade

The cause of that problem was a php function had been disabled. See the last couple of comments for a code change that fixes that particular problem.

Hi Duncan

brilliant that seems to have worked great!
interestingly even in the auto install with softabulous the themes didn’t work. i am not sure if this means that my hosting has disabled more php fonctions than most hosting companies, but it might be an idea to add this
code in the future?

@Dragonrider, i can now see the themes selection in Config>Settings page, under General Settings ( I could not see this before the fix however, weird??

anyway thanks a lot !