[SOLVED] 3.3.1 not reachable (error 500)

Still stuck here…I have no idea what to do, I also tried to put all files in an OLD dir and upload 3.3.1 then copying config but nothing…still same error and impossible to use versions >2.2.7
Any idea guys?

Going from 2.x to 3.3.x is a big jump.

The main changes are a change to the database schema, and the requirements of a proper version of phplist, and changes in the config.php file.


Well, from 2.2.7 the next version is 3.3.0, if I am not wrong, for which I had the same issues so I guess all of us had to make this step.
I followed upgrade instructions as always but something changed, what? Where can I find exact steps to follow?

here’s a list of changes…

and here are some instructions on how to upgrade:

I don’t see a version 2.2.7…

Sorry, mistyped, 3.2.7 of course :slight_smile:
That’s why I find strange not being able to upgrade to 3.3.0

Which version of php are you using? phplist now requires php 5.4 or later.

Yep I know…we’re using since long time ago 5.6.29 working fine also with 3.2.7.

Have you looked in the web server event log?
You can try enabling error reporting in the files admin/index.php and init.php. Change the existing lines from 0 to 1


Don’t overwrite files, just rename the lists directory to lists_3.2.7 then copy the new lists directory, so that you have a clean install.

I get the same issue. The problem isn’t with removing old files and uploading the new ones. The issue comes into play when you enter the database connection details. That’s when the error is thrown. Did something change with the database like charset or collation? We are currently using Mariadb 10.x.

Thanks @parkerj but no changes at all. In fact, when I reupload 3.2.7 with the same config file it works smoothly…very strange

Also thanks to @duncanc but I did made a fresh install (see above, I put everything in “OLD” dir and upload all files with no overwriting but doesn’t work.
I did this so many times until 3.2.7 and was perfect. Now 5 times to try upgrading to 3.3.0/1 but nothing…I will try again by using error reporting.

Sorry, my question was actually for @duncanc to see if the developer’s of PHPList might have done some database changes that we are unaware of.

1 Like

Ok, here my errors as in log (sorry for not having posted this earlier :S)
I never saw this error, no idea what it means :S
The error was thrown simply by trying to access /admin page from browser

PHP Fatal error: Uncaught exception ‘Exception’ with message ‘There is no suitable CSPRNG installed on your system’ in /admin/inc/random_compat/random.php:203\nStack trace:\n#0 /admin/defaultconfig.php(106): random_bytes(10)\n#1 /admin/index.php(96): require_once(’/var/www/vhosts…’)\n#2 {main}\n thrown in /admin/inc/random_compat/random.php on line 203

@michelep @parkerj You need to have either the mcrypt extension installed or the web server must be able to read the directory /dev/urandom. Check whether either of those is the case.

1 Like

But is this a new requirement for 3.3.x?

Yes, to do with making click tracking more secure.

Thanks, /dev/urandom worked for me.

Feeling dumb here…have no /dev/urandom folder :S

/dev/urandom is from the file system root. You won’t see it if you are just looking at your home directory.
Another solution is to use php 7. The code that is failing is providing a function, random_bytes(), that is now provided by php 7.

Thank you @duncanc. But did I miss all of this info in release note? Was this there? I don’t think so…