Sending stops, suspected cronjob/config problem - desperate :(

Hello all,
Recently I keep having issues with PHPLIST on my Bluehost account.
I am using PHPLIST ver 2.10.17. Shared Server, PHP version 5.2.17.
Latest thing is that a batch of messages is sent, then stops. If I click “process queue” on the browser,
sending is resumed and then stopped after some dozen emails again.

This is strange because I have a cron job defined, which has been working fine for a long time.
This is the configured cron job:
wget -q -O - ‘’ >/dev/null

Since I suspected that this is the problem now, I configured additional cron jobs based on suggestions I found in forums, but it didn’t help…

This is another one I added:

/usr/local/php5/bin/php5 -q /home/guyshach/public_html/lists/admin/index.php -p processqueue -c /home/guyshach/public_html/lists/config/config.php > /home/guyshach/public_html/lists/processqueue.log 2>&1

and another one:

php -q /home1/guyshach/public_html/lists/admin/index.php -p processqueue -c /home1/guyshach/public_html/phplist/config/config.php >/dev/null

I tried the path with “home1” because bluehost cPanel indicated that home directory is /home1/guyshach
It also didn’t work when I tried /home/guyshach.

Where did I go wrong…?


The wget output will probably show what is happening but you are discarding it. Save it to a file instead.

thanks, how do I do that…?

@guysh replace


by a path to somewhere you want the log file to be saved

> /home1/guyshach/wget.log

assuming that /home1 is correct, and not /home.

great, will try that, thanks

No file is written… not with “home” and not with “home1”…
How can I be sure that the cron job actually runs…?

Try adding this to the end of the command to capture any errors from wget. They should get added to the same log file.


If you are using cpanel then you can see what your home directory is through the File Manager. On the left side it should have the path to the home directory

thanks again, will try :slight_smile:

I found the problem!

  • First, in order to debug, I used a bluehost option that cron job sends an email every time it runs.
  • I got emails, so understood that they actually run.
  • The email stated syntax errors in the cron job command.
  • Apparently the command seemed truncated - from the “%” character that was in the admin password…!
  • I changed the password so it does not include “%” and now the cron job works!
    Thanks for your help,

Of course I should have suspected that earlier, as the problem started after I changed the password. But for someone who is not working in development regularly, a problematic character such as “%” is not an immediate option…