Scheduling doesn't work

Hi there!

the scheduling in my installation does not work properly. For expample I just scheduled a new campaign like this:

Today is the 27th of June, that mail shouldn’t be sent before 28th. But the mail was just send (cron is working every 5 mins), although we already have the 27th!

The server time and date are correct. Do you have any solutions? My phplist-version is v3.2.5.


@arada If you look at the event log then there might be some information about the campaign and when it was sent.

If you submit this campaign, what is displayed in the Status column of the Active tab of the Campaigns page? It should reflect that the embargo is in the future


thanks for your fast reply.

Here is your requested information:

Looks normal, it only was sent too early! :unamused:

And the other one:

@arada Not what I want to see. I asked you to submit that campaign again on the Finish tab, so we can see whether phplist recognises the embargo time.

@duncanc Ok, I’ve submited that capaign again on the finish tab. Then I just saw, that it is sent, but I don’t get any mail, cause I already got it before! :wink:

So I created a new campaign. I scheduled it again on 28.06.2016, 19:00, and there I pressed on “save and continue editing”. Then I turned to the list-tab, there I selected the test-list, confirmed again with “save and continue editing”, switched back to the schedule-tab and there I saw the wanted scheduled time (28.06.2016, 19:00)

I went to the finish-tab and pressed “Nachricht in Warteschlange einreihen” (don’t know what you see there in english), it’s the highlighted button over the two other ones in the bottom.

And again the Queue was processed to early! :unamused:

@arada I guess that the php time zone needs to be set.

Can you install the Timezone plugin, then see whether a timezone is displayed, menu Config > Timezones

If no timezone is displayed then you can set it on the Settings page.

Hmm, that seems to be alright, doesn’t it?

Which release of phplist are you using?
I have just noticed that in your screenshots the year is shown as two digits. In my installation it is shown as 4. Also the second field is usually 6 months after the first, but yours seems to be 6 days.

The latest version 3.2.5. I just updated it before a few days.

Should I overwrite the files on the webspace again with those downloaded on my harddisk? Or what do you would consider?

I’ve got a solution now!

I just edited the config.php like this:

Now it works. But I think, it’s an error in the code, because before updating to 3.2.5 it works with 10 as start year and 20 as end year.