I’m running 3.6.16. The notice popped up today that 3.7 was available and to use the updater. I went to do that and it never found the package to download. Just wondering if that notice was “early” and it shouldn’t be there, or if there might be an address error in the updater? Thanks.
I just looked at the phplist.org site and it only shows 3.6.16 released in May 2025 as the latest version. I’m thinking you had someone trying to phish/jack you and you should scan that system immediately. I’m a bit of the old school where is DISTRUST all popups.
Good Luck - Doug
Thanks. Yeah, I’m with you, when it didn’t find it, I scanned the system. Everything seems to be good. It is interesting that when I go to the “updater” page in the install it still says “phpList version 3.7.0 is available”. But it isn’t.
@brownmp @Dougster On Sourceforge there is a new release https://sourceforge.net/projects/phplist/files/phplist/
I have just installed that using the Updater plugin, not the core phplist updater, and the update was successful. Just clicking a few pages doesn’t show any problems.
There is actually a team working on version 3.4.x but they have not yet given a release date for it.
So, the .org site will no longer have the most recent updates in it going forward??
Does SourceForge run on twisted pair over barbed wire, it is the slowest thing in the world??!!
@brownmp Can you show a screenshot of whatever error message is being displayed?
I go to here and click the button. And then it spins for 30s - 60s. And eventually returns a “that page can’t be found” which is kicked out to the general website framework.
![]()
@brownmp Possibly caused by the download timing-out. You can try increasing the maximum time by adding this line to the $updaterConfig settings in the config.php file
'max_execution_time' => 300,
This allows the download to take up to 5 minutes, which worked in my case.
See plugin:updater [phpList Resources]
Thank you, and sorry for the time. I tried that and it still failed over to that “not found”. It did so long before the 300 secs. Might there be something else I’m missing? Or has a directory pointer been updated that I missed somehow? Thanks again.

@brownmp I don’t know. Maybe your hosting company does not allow the maximum execution time to be changed. You will need to apply the update manually.
I downloaded the zip separately and then FTP’ed it to the temp directory. The updater recognized the downloaded zip and progressed on. It all worked perfectly from there. Must be something to do with the file size. Roughly 2x the previous.
You can find all the download links for phpList 3.7.0 in this post: phpList 3.7.0 is ready for download
Happy sending!



