Phplist Problems and Solutions, SMTP and kcfinder

(using 3.2.5, installed with installotron)

I have encountered some problems on installing phplist, and spend a lot of time finding solutions, maybe the stuff can be faq’ed somewhere for others, if useful.

The problems are specific for the hosting I use, but maybe you get the same.

(1). Error while trying to send email via smtp server.

If, like in my case, you have php v 5.6 and a smtp server with a non matching server ssl certificate, connections are refused.

Solution is to open class.smtp.php in admin/PHPMailer directory and add:

if (count($options) == 0) {
       $options['ssl'] = array('verify_peer' => false, 'verify_peer_name' => false, 'allow_self_signed' => true);

above static $streamok;

(or add the right certificates ofcourse, if you can)

I want to send through smtp, because it gives me DKIM headers.

(2). kcfinder “rights” problem.

You may encounter a disabled file manager. Normally the session data is set, so the kcfinder retrieves permissions and folder data.

However, in config.php there is @ini_set(‘session.save_path’,dirname(dirname(FILE)).’/tmp’);

In my case this leads to a folder inside the root of the website /tmp with stored sessions. IMHO a bit odd, and not safe.

It also means, that kcfinder, using the default session path, does not read the correct session data.

Removing @ini_set(‘session.save_path’,dirname(dirname(FILE)).’/tmp’) makes the sessions go to the default folder (not in website root), and kcfinder is able to read permissions and correct paths.

(3). Server ERROR 500 while accessing files uploaded in kcfinder defined paths.

kcfinder uploads a htaccess file in the root of the upload folder, in order to disable nasty permissions. Good idea. It takes “upload.htaccess” from admin/plugins/CKEditorPlugin/kcfinder/conf and uploads (and checks) this file every time it is used. In my case this htaccess caused a 500 error. I removed the entry responsible for the 500 error (by trail and error), while retaining the safety otherwise provided by the htaccess.

@TonyVier There is a config variable that you can use to set the ssl options

I don’t understand your second point about kcfinder rights.

However, in config.php there is @ini_set(‘session.save_path’,dirname(dirname(FILE)).’/tmp’);

Which file are you referring to? I cannot find that line in any phplist or kcfinder file. Possibly it was added by your installer process.

Which line in the upload .htaccess file caused your problem? Possibly that should be reported to the kcfinder developer, (who is entirely unconnected with phplist).

Ah, phpmailer_smtpoptions, wrestled with this in 3.2.4

Ok, maybe this “session.save_path” was added by the installatron installer…?!? Don’t have it either in a 3.2.4 version I have…

Can’t remember exactly what I removed in the upload.htaccess file, but it was the 4th entry of the <IfModule entries, the cgi part. Maybe its a config error on the Apache server, dunno. Anyways, it works now…

Error log says: uploadimages/.htaccess: Option ExecCGI not allowed here