phpList 3.6.10 does not work with PHP 8.x on host Strato

I’ve just upgrade to PHPList 3.6.10 and also updated enabled plugins.

  • Common Pluginversion 3.23.4+20221130 by Duncan Cameron
  • CKEditor pluginversion 2.6.6+20220515 by Duncan Cameron

Now I try to switch from PHP 7.4 (which is working fine) to 8.0 or 8.1. Both are not working. I get an HTTP 500 when trying to call the PHPList admin page.
I’ve already noticed in the forum that there might be an error due to SSL connection to the database, but this seems to be not the problem with my installation as I switched the parameter on and off without any differences in behavior.
Unfortunately, I am not able to see an error log file. I added line “error_reporting(1);” to both index.php and init.php in /admin but was not able to find any file containing error messages.
My host is Strato.
Is anyone able to provide help?
Thank you in advance.
Best regards

That should be -1 not 1

But if you cannot find an error log file then you will need to ask the hosting company to find out what is failing.

Thank you for your response. I will contact the hosting company.
However, as to the “-1”: I found “1” in the PHPList manual Troubleshooting Techni... | phpList manual
Which one is correct?

@raltmeyer For trying to debug a problem -1 is best because it reports all types of errors and warnings. A value of 1 reports only fatal errors.

Any update on this. I am facing the same issue with phplist on Strato server.
Everything is working fine with phpList 3.6.10 and php 7.4. If I use php 8.0, 8.1 or 8.2 processqueue will only send 1 email but is still running in the background, meaning I cannot restart the script for another 10 min until the previous instance is stopped (600s timeout).
Also, I am not getting an errors displayed.

@Indiana.Horschd There is another topic relating to this problem with Strato. Can you try making the code change that I described in V. 3.6.10 with PHP 8.0.x Problems? - #18 by Dougster

Or try to provide a php error log that shows the problem.

I tried the “solution” from Campaign stops after 1 email if language is not englisch, and it worked.
I changed in the config.php $default_system_language from “de” to “en” and rerun the script. To my surprise, it worked!