PHPlist 3.3.1 subscriber import issues

Hey guys,

Currently having some issues importing subscribers into my database. I cant seem to import more than 3300 emails. Im not sure why that is, the previous version of 3.2.7 i could easily import more at once. Even after trying to import 3000 at a time it doesnt go into the DB. Can anyone help? UPDATE: Ive tried importing using both the csv style and the copy and paste email style

It’s been a while back when I did this, but there used to be a ‘max’ setting for file import size and upload size.

The size of the import was controlled by the maximum execution time (set in php.ini), also.

You might look at those, increasing them one at a time, until you find the variable that allows for bigger imports.

Another possibility is that you have ‘gremlins’ in your email list that you are importing (unprintable characters that don’t show up in html…). The best way to find these hidden characters is to look at the file using a text editor such as textmate or vi. If you get stuck in the same place (i.e 3300th email address), you can look at that line and make sure it is free of weird looking charachters.

Hi Dan,

Thanks for the reply but I dont think this is the case, it seems as though my database thinks those subscribers still exsist, even after deleting the entire DB and reinstalling phplist it still thinks about 5000 of the 8000 subscribers are in the DB even though when I go to the search subscriber page it says there are only 3000 emails. Another compounding problem is when I restore the old DB with 10,000 subscribers and i try to add them to a list it will only let me add a max of 3375 emails even though I could initially add as many subscribers as I wanted to a list.

I’d suggest that you look over your file with the emails in it, sort it by emails, trim the front and back of the emails from empty spaces, and dedupe the list. You can use regular expressions to do this, or a tool like textpipepro,

That might show you that you only have 3000 or so unique addresses?

Once you know that number, you should get that number of addresses when you import the file into phpList.

Where are the settings for max import, and max upload?

and where is the php.ini?

See this topic, there is no need to ask the same question in several places. :slight_smile: