back to phpList.org

No longer free?

I had my phplist (self hosted) set up to work with the free phplist.com (I think) free remote processing. Is this no longer free? It seems as though it has stopped working and I had to make a new account which makes no reference at all now to any ability to remote process the sending queue. I also just tried to set up a cron job but when I run the phplist -pprocessqueue command I get an access denied error so I cannot finish setting up the cron. Any help or answers to either one of these would be great, as having to tell my person who makes and sends my organisations newsletter isn’t very user friendly or feasible at all.

@Jstuts5797 The remote processing calls from phplist.com can be a bit hit and miss. I don’t know of a way to confirm whether they are still being made.

If you are able to create a cron job on the phplist web server then that is a much preferred approach. What is the command that you are using for the cron job?

The problem I’m having with phplist.com is now when I log in it takes me to a phplist.com hosted version of phplist instead of how it used to be where I could set up the remote processing… thats what I assumed that they no longer offered this service. How can I find what I need to set that up then? As far as setting up the cron job myself which I would honestly prefer too is the following: I used the guide provided here: https://www.phplist.org/manual/books/phplist-manual/page/setting-up-your-cron

I get to the point where it has you run the “phplist -pprocessqueue” command. When I do so I get the following error:

/home/admin/domains/mydomainhere.com/public_html/newsletter/admin/index.php: line 1: ?php: No such file or directory
/home/admin/domains/mydomainhere.com/public_html/newsletter/admin/index.php: line 3: //: Is a directory
/home/admin/domains/mydomainhere.com/public_html/newsletter/admin/index.php: line 4: syntax error near unexpected token (' /home/admin/domains/mydomainhere.com/public_html/newsletter/admin/index.php: line 4: require_once dirname(FILE).’/checkprerequisites.php’;’

The thing is… all those directories DO exist. I’m running CentOS8 on my own server so I am indeed the root user. I DO have DirectAdmin on this server as well, but I have no clue how to set up a cron job there either. This is my first time EVER trying to set up a cron job (as most things I’ve used sets it up automatically for you) so I honestly have no clue what I’m doing. I was just simply trying to follow that guide I posted above. If you can offer me ANY help at all I would greatly appreciate it!

@Jstuts5797 It looks like you have some errors in the shell script phplist.

1 Like

Is there a secure way I can show you what I put in the script?

#!/bin/bash
/home/admin/domains/mydomainname.com/public_html/newsletter/admin/index.php -c /home/admin/domains/mydomainname.com/public_html/newsletter/config/config.php $*

Obviously I have my real domain in for mydomain.com above.

@Jstuts5797 You have omitted php from the command.
The actual command to run php can vary, you can try simply php or /usr/bin/php otherwise ask your hosting company.

1 Like

Where do I need to place “php” in the above code. In this case I am the hosting company. This is on a dedicated KVM server.

@Jstuts5797 It is in the documentation that you linked to.

1 Like

BINGO! That was it! I can’t believe I missed that! It is now working just fine! I cannot thank you enough for helping me troubleshoot this!!! You rock!