back to phpList.org

Message queue shows "submitted" but never shows "processing"


#1

Hi

We are using phplist, with phpmailer, connecting to smtp port 587. We have tested succesfully:

  • send through telnet
  • send through phpmailer
  • send through phplist “test mail” button

BUT as soon as we put the message on the process queue, it shows “submitted” with a pause icon, but never sends the message, and the message never shows a “processing” state

When we try to send it through command line
/usr/local/php56/bin/php /home/user/domain/lists/admin/index.php
-pprocessqueue -c/home/user/domain/lists/config/config.php

It returns:
“phpList - A process for this page is already running and it was still alive 0 seconds ago
phpList - Running commandline, quitting. We’ll find out what to do in the next run”

Any ideas?


#2

We solve the issue. The database table phplist_sendprocess had a process registered that wasn’t really active.

We deleted that register off the table and the queue worked again

Hope it helps in any case


#3

Good morning ! I have the same problem, but that solution has not been me. Could you please help please?


#4

Your solution worked for me! thx!


#5

Hi there,

The campaign repeatedly hangs at “submitted” till I follow your solution.
But the question is what is causing this problem that each and every time one has to delete the process queue record?

I seek a permanent solution to this problem.


#6

I have this problem too. I checked the database table, but there is not entry - so the problem seems to be another.


#7

OK, I am sorry. I found the problem: I forgot to copy back my cron-scripts after an update… :relaxed: