back to phpList.org

MariaDB 10.2 Compatibility?


#1

Is the latest version of PHPList compatible with MariaDB 10.2 ? I am currently running MariaDB 10.1, and see this warning when I go to upgrade:

MariaDB enables “strict mode” by default as of version 10.2. Strict mode controls how MariaDB and MySQL handle invalid or missing values in data-change statements such as INSERT or UPDATE. Applications not built with strict mode enabled may cause undesired behavior; please verify applications using MariaDB are compatible before upgrading. More information about strict mode is available here


#2

@keeenone Is this equivalent to mysql STRICT_TRANS_TABLES ? If so then you should be ok because phplist works when that is enabled.

image


#3

So you definitely know more than I do about this…and I hope your take here is correct, as there is, according to Cpanel’s warnings, no way of downgrading once I upgrade.

So it looks as though I need strict mode enabled, or perhaps it is by default? I will check for a setting in the ACP. Thank you!


#4

No I don’t. I was just offering some information, and I don’t use MariaDB.

If you are not sure about upgrading then don’t do it.


#5

Can I ask you which table you see “STRICT_TRANS_TABLES” in? I cannot find this in my databases anywhere. Do you know where this would be set?


#6

@keeenone STRICT_TRANS_TABLES is a mysql server setting that looks to be similar to what you described as “strict mode”.