back to phpList.org

Link tracking with Google maps pages


#1

I have a link in my email

https://www.google.com/maps/place/Jack+Astor’s+Bar+%26+Grill/@43.7345959,-79.3460459,17z/data=!3m2!4b1!5s0x89d4cd7216df3c6d:0xb43516d71ae89300!4m5!3m4!1s0x89d4cd717b796be3:0x54b68eeb1833e8b4!8m2!3d43.7345959!4d-79.3438572

the email contains the link https://wanlesstennis.com/newslist/lt.php?tid=eEwIUgMBAAIAVUxQVgBRGAMAUVQZBFEHUEhRB1JZBAACCAFbVghMUwJUBFQDAgYYVAoEURlRVwECSAxXBFYYVVVSXVMABVEFDQZTHQoDBgdTAlYGGVIHC1VIAAQBUhhcCAVYTg0CVVICBVgDBgINUQ

The url rendered is https://www.google.com/maps/place/Jack+Astor/@43.63492,-79.4363013,15z/data=!3m1!4b1

I’ve tried it with link tracking off and the same thing happens when I send myself a test. (“This is a test campaign” is unchecked).


#2

@jimlongo It looks like there are a few problems when a URL includes a single quote.

I will raise an issue on Mantis, but as a workaround you can try changing the single quote in the URL to %27 . That seems to make the url work in an html email but is still wrong in a plain text email.


#3

Thank you. The workaround half worked it seems.

www.google.com/maps/place/Jack+Astor's+Bar+%26+Grill/@43.7345998,-79.3460459,17z/data=!3m2!4b1!5s0x89d4cd7216df3c6d:0xb43516d71ae89300!4m5!3m4!1s0x89d4cd717b796be3:0x54b68eeb1833e8b4!8m2!3d43.7345959!4d-79.3438572q

becomes

https://wanlesstennis.com/newslist/lt.php?tid=eEwBVVUGUVpWCUwDAg0EGAMHUA8ZXQQBWkgAAlAFAwNUBAgHVgFMUwJUBFQDAgYYVAoEURlRVwECSAxXBFYYVVVSXVMABVEFDQZTHQoDBgdTAlYGGVIHC1VIAAQBUhhcCAVYTg0CVVICBVgDBgINUQ

then
www.google.com/maps/place/Jack+Astor’s+Bar+%26+Grill/@43.7345998,-79.3460459,17z


#4

@jimlongo Which release of phplist are you using? There was a change in 3.3.5 to improve link tracking. After using %27, the link is correct for me in an html email, but the plain text is still wrong but for a separate reason.


#5

Thank you, upgrading from 3.3.3 now . . .


#6

As I said it sort of works, the map renders with the pins on it, but the mapped location is not highlighted on the map as it is in the original link. The URL stops after 17z, where in the original it’s followed by a data parameter.

But here’s a Google Maps tip that might help you. Don’t bother with copying the entire URL, instead click the Share Icon and use that URL. This will avoid any problems.


#7

@jimlongo OK, the share icon gives a shortened url, which makes sense.